aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaturneric <[email protected]>2022-01-10 16:49:06 +0000
committerSaturneric <[email protected]>2022-01-10 16:49:06 +0000
commitb51f13fe9192b1378ce69af48f1a739e021573fa (patch)
treea4338254244f797617b02f0aee7b9f982785d94c /CMakeLists.txt
parentMerge branch 'dev/ci/2.0.4' into dev/ci/2.0.5 (diff)
downloadGpgFrontend-b51f13fe9192b1378ce69af48f1a739e021573fa.tar.gz
GpgFrontend-b51f13fe9192b1378ce69af48f1a739e021573fa.zip
<feat>(project): Added configuration options for QT version constraints.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38df1d65..5b66f980 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,7 @@ option(GPGFRONTEND_BUILD_TYPE_STABLE
option(GENERATE_LINUX_INSTALL_SOFTWARE "Generate an installable version" OFF)
option(GENERATE_APP_PACKAGE_DEB "Generate DEB package" OFF)
option(CONFIGURE_FOR_XCODE_BUILD "Generate a version that can be successfully compiled and packaged in Xcode" OFF)
+option(USE_QT_DEFAULT_ENV "Build with the qt version provided by the qt-default package" OFF)
# analyse options
if (GPGFRONTEND_BUILD_TYPE_TEST_CORE)
@@ -296,6 +297,7 @@ if (LINUX_INSTALL_SOFTWARE)
include(GNUInstallDirs)
set(INSTALL_GPGFRONTEND_APP 1)
set(APP_INSTALL_FLAG LINUX_INSTALL)
+ set(USE_QT_DEFAULT_ENV ON)
add_compile_definitions(LINUX_INSTALL_BUILD)
set(Boost_USE_STATIC_LIBS ON)
else ()
@@ -353,7 +355,7 @@ find_package(Boost COMPONENTS date_time filesystem REQUIRED)
if (QT5_ENV_SUPPORT)
# Support Qt version Both 5.12.x and 5.15.x
- if (LINUX_INSTALL_SOFTWARE)
+ if (USE_QT_DEFAULT_ENV)
find_package(Qt5 COMPONENTS Core Test Widgets PrintSupport Network REQUIRED)
else ()
find_package(Qt5 5.15 COMPONENTS Core Test Widgets PrintSupport Network REQUIRED)