aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-31 06:50:07 +0000
committersaturneric <[email protected]>2024-07-31 06:50:07 +0000
commit8e99ff11a60b5e4686776fba39709bee22d96b92 (patch)
treeb039a667deb8ce9e37cacb6ee759a18aec41e44a /CMakeLists.txt
parentfix: symbol export headers relative path (diff)
downloadGpgFrontend-8e99ff11a60b5e4686776fba39709bee22d96b92.tar.gz
GpgFrontend-8e99ff11a60b5e4686776fba39709bee22d96b92.zip
fix: build pipeline
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f6bbd58..9e65ff48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,7 +173,7 @@ if(CCACHE_FOUND)
endif(CCACHE_FOUND)
# detect compiler
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "AppleClang")
# using clang
if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.0)
message(FATAL_ERROR "Clang version must be at least 9.0!")
@@ -200,7 +200,7 @@ elseif("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
message(FATAL_ERROR "MSVC is not supported.")
else()
# using a unknown compiler
- message(FATAL_ERROR "This Unknown Compiler is not supported.")
+ message(FATAL_ERROR "Compiler: ${CMAKE_CXX_COMPILER_ID} is not supported.")
endif()
# Using Standard C++-17 (Consider compatibility)