aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-25 17:15:21 +0000
committersaturneric <[email protected]>2024-07-25 17:15:21 +0000
commit85eff35d7bf01ede96629a32358c467041c9b0a3 (patch)
tree337db8c08e84fb69333336ed6459892d32b00cd8 /CMakeLists.txt
parentfix: update GeneralSettings ui file (diff)
downloadGpgFrontend-85eff35d7bf01ede96629a32358c467041c9b0a3.tar.gz
GpgFrontend-85eff35d7bf01ede96629a32358c467041c9b0a3.zip
fix: Qt6CoreConfigureFileTemplate.in does not exist
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 19 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49cd9853..7c3aecc0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,14 +368,30 @@ else ()
endif ()
if (GPGFRONTEND_QT5_BUILD)
+
add_compile_definitions(QT5_BUILD)
+
+ # Introduce Qt
+ # Support Qt version: 5.15.x
+ find_package(Qt5 5.15 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
+
else()
+
add_compile_definitions(QT6_BUILD)
+
+ # Introduce Qt
+ # Support Qt version: 6.x
+ find_package(Qt6 6 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
+
endif()
-# Basic ENV Configure
-set(BASIC_ENV_CONFIG 1)
-set(QT_MOC_CONFIG 1)
+# Qt configuration
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(CMAKE_AUTORCC_OPTIONS "--compress;9")
+set(CMAKE_AUTOUIC_SEARCH_PATHS ${CMAKE_AUTOUIC_SEARCH_PATHS} ${CMAKE_SOURCE_DIR}/ui)
if (STABLE_BUILD_APPLICATION)
message("[+] Build Stable Application")