aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-30 17:13:31 +0000
committersaturneric <[email protected]>2024-07-30 17:13:31 +0000
commit5d0b30a9152367714ad839d8e41332c0879f6a98 (patch)
tree774a5a8dd17bfc9de07c3be0ef917c9c4e5625a2 /CMakeLists.txt
parentfix: do some build config clean up (diff)
downloadGpgFrontend-5d0b30a9152367714ad839d8e41332c0879f6a98.tar.gz
GpgFrontend-5d0b30a9152367714ad839d8e41332c0879f6a98.zip
fix: use standard qt version checking macro
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbab158d..c8a4212c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -393,16 +393,9 @@ else()
endif()
if(GPGFRONTEND_QT5_BUILD)
- add_compile_definitions(QT5_BUILD)
-
- # Introduce Qt
# Support Qt version: 5.15.x
find_package(Qt5 5.15 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
-
else()
- add_compile_definitions(QT6_BUILD)
-
- # Introduce Qt
# Support Qt version: 6.x
find_package(Qt6 6 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
endif()