aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2023-10-23 13:23:37 +0000
committersaturneric <[email protected]>2023-10-23 13:23:37 +0000
commit5a3f422335b27c6c19a2d91f525c77435e8f2384 (patch)
treea72d417cc040f07fd7e21f9bd2cc70d0de5e8bed /CMakeLists.txt
parentperf: reduce header includes and improve build speed (diff)
downloadGpgFrontend-5a3f422335b27c6c19a2d91f525c77435e8f2384.tar.gz
GpgFrontend-5a3f422335b27c6c19a2d91f525c77435e8f2384.zip
fix: solve some issues on log system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 10 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd4cc951..839203fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,6 +196,13 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif ()
+if (CMAKE_BUILD_TYPE EQUAL "Release")
+ add_compile_definitions(RELEASE)
+else()
+ add_compile_definitions(DEBUG)
+endif()
+
+
# Specify different compilation modes
if (GPGFRONTEND_BUILD_CONFIG)
# Test Build
@@ -354,11 +361,6 @@ if (LINUX)
endif ()
-if (GPG_STANDALONE_MODE)
- add_compile_definitions(GPG_STANDALONE_MODE)
-endif ()
-
-
if (LINUX_INSTALL_SOFTWARE)
message(STATUS "Linux Install Traget ${CMAKE_INSTALL_PREFIX}")
include(GNUInstallDirs)
@@ -368,7 +370,6 @@ if (LINUX_INSTALL_SOFTWARE)
set(Boost_USE_STATIC_LIBS ON)
else ()
set(APP_INSTALL_FLAG BUNDLE)
- add_compile_definitions(BUNDLE_BUILD)
endif ()
# Basic ENV Configure
@@ -376,7 +377,7 @@ set(BASIC_ENV_CONFIG 1)
set(QT_MOC_CONFIG 1)
if (FULL_BUILD_APPLICATION)
- message("[-] Build Full Application")
+ message("[+] Build Full Application")
set(QT5_ENV_SUPPORT 1)
set(BUILD_CORE 1)
set(BUILD_UI 1)
@@ -385,7 +386,7 @@ if (FULL_BUILD_APPLICATION)
set(BASIC_ENV_CONFIG 1)
set(SUPPORT_MULTI_LANG 1)
elseif (MINIMUM_BUILD_APPLICATION)
- message("[-] Build Minimum Application")
+ message("[+] Build Minimum Application")
set(QT5_ENV_SUPPORT 1)
set(BUILD_CORE 1)
set(BUILD_UI 1)
@@ -393,7 +394,7 @@ elseif (MINIMUM_BUILD_APPLICATION)
set(BUILD_APPLICATION 1)
set(BASIC_ENV_CONFIG 1)
elseif (STABLE_BUILD_APPLICATION)
- message("[-] Build Stable Application")
+ message("[+] Build Stable Application")
set(QT5_ENV_SUPPORT 1)
set(BUILD_CORE 1)
set(BUILD_UI 1)