aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-02-26 12:38:30 +0000
committersaturneric <[email protected]>2024-02-26 12:38:30 +0000
commit59cdf57e8f807a0fe2505837e2eed5871ea281c8 (patch)
tree420cc23dc12ca947e39906981c8814e04b51e0c4 /CMakeLists.txt
parentfix: add English translation (diff)
downloadGpgFrontend-59cdf57e8f807a0fe2505837e2eed5871ea281c8.tar.gz
GpgFrontend-59cdf57e8f807a0fe2505837e2eed5871ea281c8.zip
feat: add user agent header when doing http request
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3230a908..eae20641 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -250,6 +250,10 @@ IF (MINGW)
${CMAKE_SOURCE_DIR}/lib/mingw
/mingw64/lib
)
+
+ # Http Request User Agent
+ set(HTTP_REQUEST_USER_AGENT "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:123.0) Gecko/20100101 Firefox/123.0")
+
endif ()
# macOS
@@ -277,6 +281,10 @@ if (APPLE)
/usr/local/lib
/opt/homebrew/lib
)
+
+ # Http Request User Agent
+ set(HTTP_REQUEST_USER_AGENT "Mozilla/5.0 (Macintosh; Intel Mac OS X 14.3; rv:123.0) Gecko/20100101 Firefox/123.0")
+
endif ()
if (UNIX AND NOT APPLE)
@@ -319,6 +327,9 @@ if (LINUX)
/usr/local/lib/
)
+ # Http Request User Agent
+ set(HTTP_REQUEST_USER_AGENT "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:123.0) Gecko/20100101 Firefox/123.0")
+
endif ()
if (LINUX_INSTALL_SOFTWARE)