aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-11-22 14:27:58 +0000
committersaturneric <[email protected]>2024-11-22 14:28:04 +0000
commit396f70b0686109a7ab245af8f8e4d234f4f18203 (patch)
tree8c0fbca0594a68ce77bf5169436b6b0d347d6e38 /CMakeLists.txt
parentfix: solve devops problems (diff)
downloadGpgFrontend-396f70b0686109a7ab245af8f8e4d234f4f18203.tar.gz
GpgFrontend-396f70b0686109a7ab245af8f8e4d234f4f18203.zip
feat: add build option GPGFRONTEND_BUILD_APP_IMAGE
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8d49a8b..d715eb77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,7 @@ option(GPGFRONTEND_BUILD_TYPE_ONLY_APPLICATION "Generate a usable SDK" OFF)
option(GPGFRONTEND_QT5_BUILD "Swith to Qt5 building mode" OFF)
option(GPGFRONTEND_GENERATE_LINUX_INSTALL_SOFTWARE "Generate an installable version" OFF)
option(GPGFRONTEND_ENABLE_ASAN "Enable ASAN" OFF)
+option(GPGFRONTEND_BUILD_APP_IMAGE "Build AppImage" OFF)
# xcode options
option(GPGFRONTEND_XCODE_TEAM_ID "GpgFrontend Apple Team ID" "NONE")
@@ -162,6 +163,10 @@ if(GPGFRONTEND_BUILD_TYPE_ONLY_APPLICATION)
set(STABLE_BUILD_ONLY_APPLICATION 1)
endif()
+if(GPGFRONTEND_BUILD_APP_IMAGE)
+ set(BUILD_APP_IMAGE 1)
+endif()
+
# C++
# options for ccache