aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gpg/Makefile.am')
-rw-r--r--tests/gpg/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/tests/gpg/Makefile.am b/tests/gpg/Makefile.am
index 034bb5e0..b50f4b07 100644
--- a/tests/gpg/Makefile.am
+++ b/tests/gpg/Makefile.am
@@ -81,15 +81,11 @@ noinst_PROGRAMS = $(c_tests) $(tests_skipped)
clean-local:
- -$(top_srcdir)/tests/start-stop-agent --stop
+ -$(TESTS_ENVIRONMENT) $(top_srcdir)/tests/start-stop-agent --stop
-rm -fR private-keys-v1.d
-export GNUPGHOME := $(abs_builddir)
-
-export GPG_AGENT_INFO :=
-
gpg-sample.stamp: $(srcdir)/$(private_keys)
- -gpgconf --kill all
+ -$(TESTS_ENVIRONMENT) gpgconf --kill all
$(MKDIR_P) ./private-keys-v1.d
for k in $(private_keys); do \
cp $(srcdir)/$$k private-keys-v1.d/$$k.key; \
@@ -97,9 +93,9 @@ gpg-sample.stamp: $(srcdir)/$(private_keys)
echo x > ./gpg-sample.stamp
pubring-stamp: $(srcdir)/pubdemo.asc gpg-sample.stamp
- $(GPG) --batch --no-permission-warning \
+ $(TESTS_ENVIRONMENT) $(GPG) --batch --no-permission-warning \
--import $(srcdir)/pubdemo.asc
- -$(GPG) --batch --no-permission-warning \
+ -$(TESTS_ENVIRONMENT) $(GPG) --batch --no-permission-warning \
--import $(srcdir)/secdemo.asc
echo x > ./pubring-stamp