aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c23c478d..393332bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -281,10 +281,11 @@ if test "$GPGSM" != "no"; then
AC_CHECK_FUNCS(funopen)
if test $ac_cv_func_funopen != yes; then
# No funopen but we can implement that in terms of fopencookie.
- AC_CHECK_FUNCS(fopencookie, AC_LIBOBJ(funopen),
- AC_MSG_ERROR([[
-No implementation of fopencookie or funopen available.
-]]))
+ if test $ac_cv_func_fopencookie = yes; then
+ AC_LIBOBJ([funopen])
+ else
+ AC_MSG_ERROR([No implementation of fopencookie or funopen available])
+ fi
fi
AC_REPLACE_FUNCS(isascii)