aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb3db3d6..90df95f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,7 @@ min_automake_version="1.10"
m4_define(my_version, [1.2.1])
m4_define(my_issvn, [yes])
-m4_define([svn_revision], m4_esyscmd([echo -n $( (svn info 2>/dev/null \
+m4_define([svn_revision], m4_esyscmd([printf "%d" $( (svn info 2>/dev/null \
|| echo 'Revision: 0')|sed -n '/^Revision:/ {s/[^0-9]//gp;q;}')]))
AC_INIT([gpgme],
[my_version[]m4_if(my_issvn,[yes],[-svn[]svn_revision])],
@@ -224,6 +224,17 @@ if test "$GCC" = yes; then
fi
fi
+# Only used for debugging, so no serious test needed (for actual
+# functionality you have to test libc as well, this only tests the
+# compiler).
+AC_CACHE_CHECK([for __thread],[gpgme_cv_tls_works],
+ AC_COMPILE_IFELSE([__thread int foo;],
+ gpgme_cv_tls_works=yes,gpgme_cv_tls_works=no))
+if test "$gpgme_cv_tls_works" = yes; then
+ AC_DEFINE(HAVE_TLS, [1], [Define if __thread is supported])
+fi
+
+
# Checks for library functions.
AC_FUNC_FSEEKO