aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 635dc8ca..b85f049b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,7 @@ AC_CHECK_HEADERS(sys/select.h)
# Type checks.
+AC_C_INLINE
AC_CHECK_SIZEOF(unsigned int)
AC_SYS_LARGEFILE
AC_TYPE_OFF_T
@@ -507,6 +508,15 @@ AH_VERBATIM([SEPCONSTANTS],
#endif
])
+AH_BOTTOM([
+/* Definition of GCC specific attributes. */
+#if __GNUC__ > 2
+# define GPGME_GCC_A_PURE __attribute__ ((__pure__))
+#else
+# define GPGME_GCC_A_PURE
+#endif
+])
+
# Substitution used for gpgme-config
GPGME_CONFIG_LIBS="-lgpgme"