aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3fed5e50..a1e9bf76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,15 @@ if test "$ac_cv_func_vasprintf" != yes; then
GNUPG_CHECK_VA_COPY
fi
+# Try to find a thread-safe version of ttyname().
+AC_REPLACE_FUNCS(ttyname_r)
+if test "$ac_cv_func_ttyname_r" != yes; then
+ AC_MSG_WARN([
+***
+*** ttyname() is not thread-safe and ttyname_r() does not exist
+***])
+fi
+
# Try to find a thread-safe version of getenv().
have_thread_safe_getenv=no
jm_GLIBC21