aboutsummaryrefslogtreecommitdiffstats
path: root/lang/qt/doc/Makefile.am
diff options
context:
space:
mode:
authorAndre Heinecke <[email protected]>2016-04-11 16:10:54 +0000
committerAndre Heinecke <[email protected]>2016-04-11 16:10:54 +0000
commita1e95f36ce1895cd9894f6d3ca76640c42c2f9fc (patch)
treef4b45db655220133092211ebd465ed221b9b5f4e /lang/qt/doc/Makefile.am
parentQt: Fix unit test by adding initial.test dep (diff)
downloadgpgme-a1e95f36ce1895cd9894f6d3ca76640c42c2f9fc.tar.gz
gpgme-a1e95f36ce1895cd9894f6d3ca76640c42c2f9fc.zip
Qt: Add doc generation with doxygen
* configure.ac: Look for doxygen if qt is built. Configure new files. * lang/qt/doc/Doxyfile.in: New. * lang/qt/doc/Makefile.am: New. * lang/qt/README: Update. -- Currently this is a standard doxyfile template without much customization.
Diffstat (limited to '')
-rw-r--r--lang/qt/doc/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/qt/doc/Makefile.am b/lang/qt/doc/Makefile.am
new file mode 100644
index 00000000..ddf49351
--- /dev/null
+++ b/lang/qt/doc/Makefile.am
@@ -0,0 +1,31 @@
+# Makefile.am - Makefile for GPGME Qt docs.
+# Copyright (C) 2016 Intevation GmbH
+#
+# This file is part of GPGME.
+#
+# GPGME is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# GPGME is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
+# Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in
+
+if HAVE_DOXYGEN
+doxyfile.stamp:
+ $(DOXYGEN) Doxyfile
+ touch doxyfile.stamp
+
+CLEANFILES = doxyfile.stamp
+
+all-local: doxyfile.stamp
+clean-local:
+ rm -rf $(abs_builddir)/generated
+endif