aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python/setup.py
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-06-09 10:38:50 +0000
committerJustus Winter <[email protected]>2016-06-16 12:07:41 +0000
commit7eef399d89d4c3877cb795ed5ba45ecb241e67be (patch)
tree288b45feafce4887c6b4153f0088da874e7c611e /lang/python/setup.py
parentpython: Fix exception leak. (diff)
downloadgpgme-7eef399d89d4c3877cb795ed5ba45ecb241e67be.tar.gz
gpgme-7eef399d89d4c3877cb795ed5ba45ecb241e67be.zip
python: Get version information from the build system.
* configure.ac: Generate 'setup.py' and 'version.py'. * lang/python/Makefile.am: Use generated setup script. * lang/python/pyme/version.py: Turn it into a template, and get version information from the build system. Also drop some variables. * lang/python/setup.py: Likewise. This way we can avoid importing the version module, which is frowned upon and actually caused a problem. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rwxr-xr-xlang/python/setup.py.in (renamed from lang/python/setup.py)21
1 files changed, 7 insertions, 14 deletions
diff --git a/lang/python/setup.py b/lang/python/setup.py.in
index 0d904036..9e6e0085 100755
--- a/lang/python/setup.py
+++ b/lang/python/setup.py.in
@@ -1,8 +1,6 @@
#!/usr/bin/env python3
-
-# Module: installer
-# COPYRIGHT #
+# Copyright (C) 2016 g10 Code GmbH
# Copyright (C) 2004 Igor Belyi <[email protected]>
# Copyright (C) 2002 John Goerzen <[email protected]>
#
@@ -19,15 +17,11 @@
# You should have received a copy of the GNU Lesser General Public
# License along with this library; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-# END OF COPYRIGHT #
from distutils.core import setup, Extension
import os, os.path, sys
import subprocess
-sys.path.insert(0, os.path.dirname(__file__))
-import pyme.version
-
def getconfig(what):
confdata = subprocess.Popen(["../../src/gpgme-config", "--%s" % what],
stdout=subprocess.PIPE).communicate()[0]
@@ -80,14 +74,13 @@ swige = Extension("pyme._pygpgme", ["gpgme_wrap.c", "helpers.c"],
extra_link_args = libs)
setup(name = "pyme",
- version=pyme.version.versionstr,
- description=pyme.version.description,
- author=pyme.version.author,
- author_email=pyme.version.author_email,
- url=pyme.version.homepage,
+ version="@VERSION@",
+ description='Python bindings for GPGME GnuPG cryptography library',
+ author='The GnuPG hackers',
+ author_email='[email protected]',
+ url='https://www.gnupg.org',
ext_modules=[swige],
packages = ['pyme', 'pyme.constants', 'pyme.constants.data',
'pyme.constants.keylist', 'pyme.constants.sig'],
- license=pyme.version.copyright + \
- ", Licensed under the GPL version 2 and the LGPL version 2.1"
+ license="LGPL2.1+ (the library), GPL2+ (tests and examples)"
)