aboutsummaryrefslogtreecommitdiffstats
path: root/lang/py3-pyme/debian/rules
diff options
context:
space:
mode:
authorBen McGinnes <[email protected]>2015-05-05 17:09:44 +0000
committerBen McGinnes <[email protected]>2015-05-05 17:09:44 +0000
commitebd8734ad705afa4edc409787a00d4968d25e018 (patch)
tree9fa19302510c3cde9bf9f2c5385f786128af9b03 /lang/py3-pyme/debian/rules
parentPost release updates. (diff)
downloadgpgme-ebd8734ad705afa4edc409787a00d4968d25e018.tar.gz
gpgme-ebd8734ad705afa4edc409787a00d4968d25e018.zip
Python 3 port of PyME
* The entirety of the Python 3 port of PyME up to commit 2145348ec54c6027f2ea20f695de0277e2871405 * The old commit log has been saved as lang/py3-pyme/docs/old-commits.log * Can be viewed as a normal (separate) git repository at https://github.com/adversary-org/pyme3 * Utilising the submodule feature of git was deliberately skipped on humanitarian grounds (in order to prevent pain and suffering on the part of anyone having to manage this repository).
Diffstat (limited to 'lang/py3-pyme/debian/rules')
-rwxr-xr-xlang/py3-pyme/debian/rules99
1 files changed, 99 insertions, 0 deletions
diff --git a/lang/py3-pyme/debian/rules b/lang/py3-pyme/debian/rules
new file mode 100755
index 00000000..0e886ee9
--- /dev/null
+++ b/lang/py3-pyme/debian/rules
@@ -0,0 +1,99 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=4
+
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE) swig
+ python2.4 setup.py build -b `pwd`/build
+ python2.5 setup.py build -b `pwd`/build
+ $(MAKE) PYSRCURL=file:/usr/share/pyshared/\\1 docs
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) reallyclean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/pyme.
+ python2.4 setup.py install --root=`pwd`/debian/python-pyme
+ python2.5 setup.py install --root=`pwd`/debian/python-pyme
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs -i -XCVS
+ dh_installexamples -i -XCVS
+ dh_installmenu -i
+ dh_installchangelogs -i
+ dh_link -i
+ dh_strip -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_pycentral -i
+ dh_installdeb -i
+ dh_shlibdeps -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs -a -XCVS
+ dh_installexamples -a -XCVS
+ dh_installmenu -a
+ dh_installchangelogs -a
+ dh_link -a
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_pycentral -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure