aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2007-01-10 10:18:05 +0000
committerWerner Koch <[email protected]>2007-01-10 10:18:05 +0000
commitcc5190ffc1bdef706df2d6fe7e1e5491fb28c708 (patch)
tree3ff952c7145730f7c3913532d66fe3e2c6975b38 /configure.ac
parentFixes for building without gpgsm and for W32 (diff)
downloadgpgme-cc5190ffc1bdef706df2d6fe7e1e5491fb28c708.tar.gz
gpgme-cc5190ffc1bdef706df2d6fe7e1e5491fb28c708.zip
/
* configure.ac (NEED_GPG_VERSION, (NEED_GPGSM_VERSION): Must define after it may have been changed by an option. * configure.ac: Require gpg-error 1.4 due to the use of gpg_error_from_syserror. (HAVE_ASSUAN_H): New. gpgme/ * ttyname_r.c (ttyname_r) [W32]: Return a dummy name. * version.c (do_subsystem_inits): Do assuan init only if building with Assuan. * setenv.c: Include assuan-def.h only if building with Assuan support. * op-support.c (_gpgme_op_reset): Set LC_MESSAGES only if if defined. * engine-gpgsm.c (gpgsm_set_locale): Ditto. * rungpg.c (gpg_set_locale): Ditto.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2e3c4e7b..09384b8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,10 +87,6 @@ AC_PROG_CC
AC_SUBST(LIBGPGME_LT_CURRENT)
AC_SUBST(LIBGPGME_LT_AGE)
AC_SUBST(LIBGPGME_LT_REVISION)
-AC_DEFINE_UNQUOTED(NEED_GPG_VERSION, "$NEED_GPG_VERSION",
- [Min. needed GnuPG version.])
-AC_DEFINE_UNQUOTED(NEED_GPGSM_VERSION, "$NEED_GPGSM_VERSION",
- [Min. needed GPGSM version.])
AC_SUBST(PACKAGE)
AC_SUBST(VERSION)
@@ -273,6 +269,11 @@ if test "$NEED_GPGSM_VERSION" = "no"; then
NEED_GPGSM_VERSION=0.0.0
fi
+AC_DEFINE_UNQUOTED(NEED_GPG_VERSION, "$NEED_GPG_VERSION",
+ [Min. needed GnuPG version.])
+AC_DEFINE_UNQUOTED(NEED_GPGSM_VERSION, "$NEED_GPGSM_VERSION",
+ [Min. needed GPGSM version.])
+
NO_OVERRIDE=no
AC_ARG_WITH(gpg,