aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Heinecke <[email protected]>2016-04-03 12:46:51 +0000
committerAndre Heinecke <[email protected]>2016-04-03 12:46:51 +0000
commitc07aaef6eb8a9b5e623479f27d562fd1570bf4bb (patch)
treedb5fac0d76418019f11ffe9a9f4e5e2e7658b872 /configure.ac
parentQt: Add static factor methods for protocol (diff)
downloadgpgme-c07aaef6eb8a9b5e623479f27d562fd1570bf4bb.tar.gz
gpgme-c07aaef6eb8a9b5e623479f27d562fd1570bf4bb.zip
Cpp: Require c++ 11 if cpp binding requested
* configure.ac: Call ax_cxx_compile_stdcxx * m4/ax_cxx_compile_stdcxx.m4 -- Depending on c++11 is intended to make the port away from Boost easier. The m4 macro was taken from the website mentioned in the License header of the file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8580be7b..b6b67ef3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -266,6 +266,12 @@ for language in $enabled_languages; do
AC_MSG_ERROR([unsupported language binding specified])
fi
done
+# Enable C++ 11 if cpp language is requested
+LIST_MEMBER("cpp", $enabled_languages)
+if test "$found" = "1"; then
+ AX_CXX_COMPILE_STDCXX(11, noext, optional)
+fi
+
# Check that if qt is enabled cpp also is enabled
LIST_MEMBER("qt", $enabled_languages)
if test "$found" = "1"; then