aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2002-06-02 19:19:25 +0000
committerMarcus Brinkmann <[email protected]>2002-06-02 19:19:25 +0000
commitae0d104de2fd61408387f098d6fba96b274f29d0 (patch)
treeb040e6676981c26ffa92124a75a399e02bade535 /configure.ac
parentsync our cryptplug.h with the version in KDE/libkdenetwork/ that was correcte... (diff)
downloadgpgme-ae0d104de2fd61408387f098d6fba96b274f29d0.tar.gz
gpgme-ae0d104de2fd61408387f098d6fba96b274f29d0.zip
2002-06-02 Marcus Brinkmann <[email protected]>
* configure.ac: Add checks for Pth and pthreads. * acinclude.m4: Add slightly hacked check for pth (seems to be an autoconf version problem). gpgme/ 2002-06-02 Marcus Brinkmann <[email protected]> * Makefile.am (ath_components): New variable. (ath_components_pthread): Likewise. (ath_components_pth): Likewise. (system_components): Add ath_componentes. * ath.h: New file. * ath.c: Likewise. * ath-pthread.c: Likewise. * ath-pth.c: Likewise. * posix-sema.c (_gpgme_sema_cs_enter): Rework to use the ATH interface. * mutex.h: Remove file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e160e1a..afdf4c90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,12 +99,24 @@ case "${target}" in
#component_system='COM+'
;;
*)
+ AC_CHECK_PTH(1.2.0,,,no,have_pth=yes)
+ if test "$have_pth" = yes; then
+ AC_DEFINE(HAVE_PTH, ,[Define if we have Pth.])
+ CFLAGS="$CFLAGS $PTH_CFLAGS"
+ fi
+ AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
+ if test "$have_pthread" = yes; then
+ AC_DEFINE(HAVE_PTHREAD, ,[Define if we have pthread.])
+ fi
+
dnl # XXX: Probably use exec-prefix here?
dnl GPG_DEFAULT='/usr/bin/gpg'
dnl GPGSM_DEFAULT='/usr/bin/gpgsm'
;;
esac
AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = "yes")
+AM_CONDITIONAL(HAVE_PTH, test "$have_pth" = "yes")
+AM_CONDITIONAL(HAVE_PTHREAD, test "$have_pthread" = "yes")
dnl
dnl Checks for libraries.