aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-06-09 10:38:50 +0000
committerJustus Winter <[email protected]>2016-06-16 12:07:41 +0000
commit7eef399d89d4c3877cb795ed5ba45ecb241e67be (patch)
tree288b45feafce4887c6b4153f0088da874e7c611e /configure.ac
parentpython: Fix exception leak. (diff)
downloadgpgme-7eef399d89d4c3877cb795ed5ba45ecb241e67be.tar.gz
gpgme-7eef399d89d4c3877cb795ed5ba45ecb241e67be.zip
python: Get version information from the build system.
* configure.ac: Generate 'setup.py' and 'version.py'. * lang/python/Makefile.am: Use generated setup script. * lang/python/pyme/version.py: Turn it into a template, and get version information from the build system. Also drop some variables. * lang/python/setup.py: Likewise. This way we can avoid importing the version module, which is frowned upon and actually caused a problem. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b84b04bc..42695403 100644
--- a/configure.ac
+++ b/configure.ac
@@ -775,7 +775,10 @@ AC_CONFIG_FILES(lang/qt/tests/Makefile)
AC_CONFIG_FILES([lang/Makefile lang/cl/Makefile lang/cl/gpgme.asd])
AM_COND_IF([HAVE_DOXYGEN], [AC_CONFIG_FILES([lang/qt/doc/Doxyfile])])
AC_CONFIG_FILES(lang/qt/doc/Makefile)
-AC_CONFIG_FILES([lang/python/Makefile lang/python/tests/Makefile])
+AC_CONFIG_FILES([lang/python/Makefile
+ lang/python/setup.py
+ lang/python/pyme/version.py
+ lang/python/tests/Makefile])
AC_OUTPUT
echo "