aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Heinecke <[email protected]>2016-05-19 09:14:24 +0000
committerAndre Heinecke <[email protected]>2016-05-19 09:16:15 +0000
commit2f748b5a2d162be4f23b18782219771ead54cb51 (patch)
tree9ff5f13e9b1d649c0e31a14e96ac910f7c6a80b6 /configure.ac
parentpython: Add more tests. (diff)
downloadgpgme-2f748b5a2d162be4f23b18782219771ead54cb51.tar.gz
gpgme-2f748b5a2d162be4f23b18782219771ead54cb51.zip
Qt: Check for graphviz and set HAVE_DOT correctly
* configure.ac: Check for graphviz and define HAVE_DOT. * lang/qt/doc/Doxyfile.in (HAVE_DOT): Use variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1472132a..75595599 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,10 +334,20 @@ if test "$found" = "1"; then
# This is not highlighted becase it's not really important.
then AC_MSG_WARN([Doxygen not found - Qt binding doc will not be built.])
fi
+ AC_CHECK_PROGS([GRAPHVIZ], [dot])
+ if test -z "$GRAPHVIZ";
+ then AC_MSG_WARN([Graphviz not found - Qt binding doc will not have diagrams.])
+ fi
fi
fi
AM_CONDITIONAL([HAVE_DOXYGEN],
[test -n "$DOXYGEN"])
+if test -n "$GRAPHVIZ"; then
+ HAVE_DOT="YES"
+else
+ HAVE_DOT="NO"
+fi
+AC_SUBST(HAVE_DOT)
# Python bindings.
LIST_MEMBER("python", $enabled_languages)