aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2012-01-19 17:43:10 +0000
committerWerner Koch <[email protected]>2012-01-19 17:43:10 +0000
commit2f304957f5122a5d9da643dc9951ee67ece06eaf (patch)
tree28480421eea8cc5b8be21873015d0e910edf67b8 /configure.ac
parentTry to make configure.ac a bit smaller. (diff)
downloadgpgme-2f304957f5122a5d9da643dc9951ee67ece06eaf.tar.gz
gpgme-2f304957f5122a5d9da643dc9951ee67ece06eaf.zip
Fix Solaris problems with ttyname_r.
* m4/gnupg-ttyname.m4: New. Based on ttyname_r from gnulib. * src/ttyname_r.c (_gpgme_ttyname_r): Rename from ttyname_r. Implement hacks required for Solaris and possible other non-fully Posix systems. * src/util.h: Include unistd.h. Redefine ttyname_r depending on REPLACE_TTYNAME_R and put it into the gpgme name space. -- Unfortunately we cant not use the ttyname_r replacement from gnulib because we want to keep GPGME LGPLv2+.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ed9c4b7..6e0967c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,6 @@ AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = yes)
if test "$have_w32_system" = yes; then
AC_DEFINE(HAVE_W32_SYSTEM,1,
[Defined if we run on any kind of W32 API based system])
- ACSUBST
fi
AM_CONDITIONAL(HAVE_W32_SYSTEM, test "$have_w32_system" = yes)
@@ -286,7 +285,7 @@ if test "$ac_cv_func_vasprintf" != yes; then
fi
# Try to find a thread-safe version of ttyname().
-AC_REPLACE_FUNCS(ttyname_r)
+gnupg_REPLACE_TTYNAME_R
if test "$ac_cv_func_ttyname_r" != yes; then
AC_MSG_WARN([
***