aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2002-12-23 23:45:28 +0000
committerMarcus Brinkmann <[email protected]>2002-12-23 23:45:28 +0000
commit1bf2a7b4a2737eb7de9f788c7103d54c0928bab2 (patch)
tree51aff6377f836d19ea5dab3ef5120cc38ce61713 /configure.ac
parentFix last change. (diff)
downloadgpgme-1bf2a7b4a2737eb7de9f788c7103d54c0928bab2.tar.gz
gpgme-1bf2a7b4a2737eb7de9f788c7103d54c0928bab2.zip
2002-12-24 Marcus Brinkmann <[email protected]>
* configure.ac: New conditional HAVE_LD_VERSION_SCRIPT. Call AC_CANONICAL_HOST, use host instead target. gpgme/ 2002-12-24 Marcus Brinkmann <[email protected]> * libgpgme.vers: New file. * Makefile.am (EXTRA_DIST): Add libgpgme.vers. (libgpgme_version_script_cmd): New variable. (libgpgme_la_LDFLAGS): Add libgpgme_version_script_cmd here. (libgpgme_la_DEPENDENCIES): New variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 67ce878d..fec653dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,10 +81,24 @@ dnl Don't default to build static libs.
dnl AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+AC_CANONICAL_HOST
+# For now we hardcode the use of version scripts. It would be better
+# to write a test for this or even implement this within libtool.
+have_ld_version_script=no
+case "${host}" in
+ *-*-linux*)
+ have_ld_version_script=yes
+ ;;
+ *-*-gnu*)
+ have_ld_version_script=yes
+ ;;
+esac
+AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
+
GPG_DEFAULT=no
GPGSM_DEFAULT=no
component_system=None
-case "${target}" in
+case "${host}" in
*-*-mingw32* | i?86-emx-os2 | i?86-*-os2*emx | i?86-*-msdosdjgpp* )
# special stuff for Windoze NT
# OS/2 with the EMX environment