aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2009-10-30 14:21:08 +0000
committerMarcus Brinkmann <[email protected]>2009-10-30 14:21:08 +0000
commit9d3fdd8c96b79ecbd56cf6b1a424bb2e2cd5236d (patch)
treec5e21b62188f0464553aec85047f468623dec3c7 /configure.ac
parentSome additions. (diff)
downloadgpgme-9d3fdd8c96b79ecbd56cf6b1a424bb2e2cd5236d.tar.gz
gpgme-9d3fdd8c96b79ecbd56cf6b1a424bb2e2cd5236d.zip
2009-10-30 Marcus Brinkmann <[email protected]>
* configure.ac: Check for argp.h and error_t. src/ 2009-10-30 Marcus Brinkmann <[email protected]> * Makefile.am (noinst_PROGRAMS): New target gpgme-tool. (gpgme_tool_LDADD): New variable. * gpgme-tool.c: New file. * ops.h (_gpgme_sig_notation_clearm _gpgme_signers_clear): New prototypes. * gpgme.c (gpgme_set_protocol): Allow GPGME_PROTOCOL_GPGCONF (when had that gone missing?). (_gpgme_sig_notation_clear): New function without debug output. (gpgme_release): Call it and _gpgme_signers_clear. * signers.c (_gpgme_signers_clear): New function without debug output. * g13.c (gpgme_op_vfs_mount): Add debug output. * assuan-support.c (my_spawn): Allow fd_child_list to be NULL. * conversion.c (_gpgme_encode_percent_string): Fix infinite loop. * debug.h: Put tag in front of debug lines, should make for nicer output. * engine-assuan.c (llass_new): Use our new system hooks for libassuan. * engine-g13.c (g13_new): Remove redundant assuan context allocation. * version.c (gpgme_check_version_internal): Delay debug output until after gpgme_check_version was called.
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d0be30a..3cd7c0b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -850,6 +850,14 @@ LTLIBOBJS=`echo "$LIB@&t@OBJS" |
sed 's,\.[[^.]]* ,.lo ,g;s,\.[[^.]]*$,.lo,'`
AC_SUBST(LTLIBOBJS)
+# Some checks for gpgme-tool
+AC_CHECK_HEADER([argp.h])
+AC_CHECK_TYPES([error_t], [],
+ [AC_DEFINE([error_t], [int],
+ [Define to a type to use for `error_t' if it is not otherwise available.])],
+ [#include <errno.h>])
+
+
# Last check.
die=no
if test "$require_libassuan" = "no"; then