aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2002-03-18 00:04:06 +0000
committerMarcus Brinkmann <[email protected]>2002-03-18 00:04:06 +0000
commit6cee0a4f3f060029531d7feaf7fe76f5c9d4196c (patch)
tree977b3783bc6489736bf67c5eaccf605b9ec705b1 /configure.ac
parent2002-03-17 Marcus Brinkmann <[email protected]> (diff)
downloadgpgme-6cee0a4f3f060029531d7feaf7fe76f5c9d4196c.tar.gz
gpgme-6cee0a4f3f060029531d7feaf7fe76f5c9d4196c.zip
2002-03-17 Marcus Brinkmann <[email protected]>
* configure.ac: Add automake conditional HAVE_DOSISH_SYSTEM. gpgme/ 2002-03-18 Marcus Brinkmann <[email protected]> * Makefile.am (system_components): New variable, set depending on HAVE_DOSISH_SYSTEM. (libgpgme_la_SOURCES): Use system_components. Remove `syshdr.h'. * syshdr.h: File removed. * posix-io.c: Remove !HAVE_DOSISH_SYSTEM safeguard. Clean up source. * posix-sema.c: Likewise. * posix-util.c: Likewise. * w32-io.c: Remove HAVE_DOSISH_SYSTEM safeguard. * w32-sema.c: Likewise. * w32-util.c: Likewise. * posix-io.c: Include `unistd.h', do not include `syshdr.h'. * posix-sema.c: Likewise. * w32-io.c: Include `io.h', do not include `syshdr.h' * w32-sema.c: Likewise. * w32-util.c: Likewise. * data.c: Do not include `syshdr.h'. * wait.c: Likewise. * wait.h: Code cleanup. * mutex.h: New file. * posix-sema.c: Implement.
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d28a7a61..59bcc350 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,7 @@ case "${target}" in
# DOS with the DJGPP environment
AC_DEFINE(HAVE_DRIVE_LETTERS)
AC_DEFINE(HAVE_DOSISH_SYSTEM)
+ have_dosish_system=yes
GPG_DEFAULT='c:\\gnupg\\gpg.exe'
GPGSM_DEFAULT='c:\\gnupg\\gpgsm.exe'
#component_system='COM+'
@@ -82,6 +83,7 @@ dnl GPG_DEFAULT='/usr/bin/gpg'
dnl GPGSM_DEFAULT='/usr/bin/gpgsm'
;;
esac
+AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = "yes")
dnl
dnl Checks for libraries.