aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Heinecke <[email protected]>2016-03-03 11:46:53 +0000
committerAndre Heinecke <[email protected]>2016-03-08 13:28:31 +0000
commit58ed9c17f00f420035ecc6973a6c6ed948757a9a (patch)
tree50632f47f829a3d9156ad89eec3c4ddbfc1886d5 /configure.ac
parentAdd version info for gpgmepp (diff)
downloadgpgme-58ed9c17f00f420035ecc6973a6c6ed948757a9a.tar.gz
gpgme-58ed9c17f00f420035ecc6973a6c6ed948757a9a.zip
Remove obsolete w32-qt code
* configure.ac (w32-qt): Remove option and Qt checks. * src/Makefile.am: Remove BUILD_W32_QT handling. * src/kdpipeiodevice.cpp, src/kdpipeiodevice.h, src/kdpipeiodevice.moc, src/w32-qt-io.cpp: Removed. -- This code was intended for Kleopatra but Kleopatra is not using it anymore. QGpgme/dataprovider is a better replacement for this.
Diffstat (limited to '')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 5aad9f40..c3a46ae7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,20 +180,9 @@ case "${host}" in
AC_ARG_ENABLE(w32-glib,
AC_HELP_STRING([--enable-w32-glib], [build GPGME Glib for W32]),
build_w32_glib=$enableval)
-
- # Check disabled, because the qt-dev packages in gpg4win do
- # not provide any support for cross compilation.
- # PKG_CHECK_MODULES(QT4_CORE, QtCore)
-
- # Use it like this:
- # ./configure --enable-w32-qt QT4_CORE_CFLAGS="..." QT4_CORE_LIBS="..."
- AC_SUBST(QT4_CORE_CFLAGS)
- AC_SUBST(QT4_CORE_LIBS)
- AC_ARG_ENABLE(w32-qt,
- AC_HELP_STRING([--enable-w32-qt], [build GPGME Qt for W32]),
- build_w32_qt=$enableval)
- ;;
+ ;;
*)
+
AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
if test "$have_pthread" = yes; then
AC_DEFINE(HAVE_PTHREAD, ,[Define if we have pthread.])
@@ -239,7 +228,6 @@ fi
AM_CONDITIONAL(HAVE_ANDROID_SYSTEM, test "$have_android_system" = yes)
AM_CONDITIONAL(BUILD_W32_GLIB, test "$build_w32_glib" = yes)
-AM_CONDITIONAL(BUILD_W32_QT, test "$build_w32_qt" = yes)
AM_CONDITIONAL(HAVE_PTHREAD, test "$have_pthread" = "yes")