aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Heinecke <[email protected]>2016-03-02 17:41:42 +0000
committerAndre Heinecke <[email protected]>2016-03-02 17:41:42 +0000
commit77c3fb450c7adf36804a55d76ff49a06a71d22a0 (patch)
treed5e97865c15f2d8f12d882302a8d12bb01b641b5 /configure.ac
parentFix export header and windows export macros (diff)
downloadgpgme-77c3fb450c7adf36804a55d76ff49a06a71d22a0.tar.gz
gpgme-77c3fb450c7adf36804a55d76ff49a06a71d22a0.zip
Add cmake configuration files
* configure.ac: Add libgpgmepp version. Configure cmake files. * lang/cpp/src/Makefile.am: Add targets for cmake files. (EXTRA_DIST): Add cmake files. -- This should smooth the transition for downstream users that have worked with KF5::Gpgmepp previously.
Diffstat (limited to '')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc5f99e3..5aad9f40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,10 @@ LIBGPGME_LT_CURRENT=25
LIBGPGME_LT_AGE=14
LIBGPGME_LT_REVISION=0
+LIBGPGMEPP_LT_CURRENT=3
+LIBGPGMEPP_LT_AGE=0
+LIBGPGMEPP_LT_REVISION=0
+
# If the API is changed in an incompatible way: increment the next counter.
GPGME_CONFIG_API_VERSION=1
##############################################
@@ -104,6 +108,9 @@ AC_CHECK_PROGS(GITLOG_TO_CHANGELOG, gitlog-to-changelog, [gitlog-to-changelog])
AC_SUBST(LIBGPGME_LT_CURRENT)
AC_SUBST(LIBGPGME_LT_AGE)
AC_SUBST(LIBGPGME_LT_REVISION)
+AC_SUBST(LIBGPGMEPP_LT_CURRENT)
+AC_SUBST(LIBGPGMEPP_LT_AGE)
+AC_SUBST(LIBGPGMEPP_LT_REVISION)
AC_SUBST(PACKAGE)
AC_SUBST(VERSION)
@@ -653,6 +660,8 @@ AC_CONFIG_FILES(Makefile src/Makefile
src/gpgme.h)
AC_CONFIG_FILES(src/gpgme-config, chmod +x src/gpgme-config)
AC_CONFIG_FILES(lang/cpp/Makefile lang/cpp/src/Makefile)
+AC_CONFIG_FILES(lang/cpp/src/GpgmeppConfig.cmake.in)
+AC_CONFIG_FILES(lang/cpp/src/GpgmeppConfigVersion.cmake)
AC_CONFIG_FILES([lang/Makefile lang/cl/Makefile lang/cl/gpgme.asd])
AC_OUTPUT