aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2001-11-21 21:31:07 +0000
committerMarcus Brinkmann <[email protected]>2001-11-21 21:31:07 +0000
commit75e7fc2e245aabf7c67d2374a51b60c96b0303f9 (patch)
tree756bea4913d579aa86c29abb0fa9638b51affb9f /configure.ac
parent. (diff)
downloadgpgme-75e7fc2e245aabf7c67d2374a51b60c96b0303f9.tar.gz
gpgme-75e7fc2e245aabf7c67d2374a51b60c96b0303f9.zip
2001-11-21 Marcus Brinkmann <[email protected]>
* Makefile.am (gpgmeplug): New variable, set to gpgmeplug if [BUILD_GPGMEPLUG]. * configure.ac (AC_CONFIG_FILES): Add gpgmeplug/Makefile. Support --enable-gpgmeplug.
Diffstat (limited to '')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bf3a5719..27a77ee1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,6 +183,12 @@ AM_CONDITIONAL(BUILD_ASSUAN, test "$GPGSM" != "no")
AM_CONDITIONAL(BUILD_COMPLUS, test "$component_system" = "COM+")
AM_CONDITIONAL(BUILD_BONOBO, test "$component_system" = "Bonobo")
+GPGMEPLUG=no
+AC_ARG_ENABLE(gpgmeplug,
+ AC_HELP_STRING([--enable-gpgmeplug], [build Gpgme Crypt Plug-In]),
+ GPGMEPLUG=$enableval)
+AM_CONDITIONAL(BUILD_GPGMEPLUG, test "$GPGMEPLUG" = "yes")
+
dnl Make the version number in gpgme/gpgme.h the same as the one here.
dnl (this is easier than to have a *.in file just for one substitution)
GNUPG_FIX_HDR_VERSION(gpgme/gpgme.h, GPGME_VERSION)
@@ -195,7 +201,7 @@ AC_SUBST(GPGME_CFLAGS)
AC_CONFIG_FILES(Makefile assuan/Makefile jnlib/Makefile gpgme/Makefile
tests/Makefile doc/Makefile
- bonobo/Makefile complus/Makefile)
+ bonobo/Makefile complus/Makefile gpgmeplug/Makefile)
AC_CONFIG_FILES(gpgme/gpgme-config, chmod +x gpgme/gpgme-config)
AC_OUTPUT
@@ -207,4 +213,6 @@ echo "
GpgSM version: min. $NEED_GPGSM_VERSION
GpgSM path: $GPGSM
+
+ GpgME CryptPlug: $GPGMEPLUG
"