aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2007-07-08 15:46:10 +0000
committerMarcus Brinkmann <[email protected]>2007-07-08 15:46:10 +0000
commit5b8e76a5334259a844ff973938b77d3e92e26f8b (patch)
treec18fe477fd6f524214ed90f6127c043f43325abc /configure.ac
parent2007-07-04 Marcus Brinkmann <[email protected]> (diff)
downloadgpgme-5b8e76a5334259a844ff973938b77d3e92e26f8b.tar.gz
gpgme-5b8e76a5334259a844ff973938b77d3e92e26f8b.zip
2007-07-08 Marcus Brinkmann <[email protected]>
* configure.ac (GPGSM_DEFAULT) [*-mingw32*]: Initialize it. (HAVE_ASSUAN_H): Set to 1 if we have it. (funopen): Use AC_REPLACE_FUNCS. (USE_DESCRIPTOR_PASSING): Define to 1 if we have it. Do not define it at all if we don't. (NETLIBS) [have_w32_system]: Add -lws2_32. (DIRSEP_C, DIRSEP_S, EXPSEP_C, EXPSEP_S, PATHSEP_S) [HAVE_DOSISH_SYSTEM]: Remove definitions. * assuan/assuan.h (_assuan_funopen): Define to _gpgme_funopen. * assuan/funopen.c: Move to ../gpgme/funopen.c. * assuan/Makefile.am (libassuan_la_SOURCES): Remove funopen.c. assuan/ 2007-07-08 Marcus Brinkmann <[email protected]> * assuan-defs.h (struct assuan_context_s): Have partial peercred structure even if HAVE_W32_SYSTEM, and have full peercred structure only if HAVE_SO_PEERCRED. * assuan-connect.c (assuan_get_peercred) [!HAVE_SO_PEERCRED]: Do not try to set PID, UID and GID. gpgme/ 2007-07-08 Marcus Brinkmann <[email protected]> * engine-gpgsm.c [HAVE_W32_SYSTEM]: Enable the bunch of the file. * funopen.c (funopen): Rename to _gpgme_funopen.
Diffstat (limited to '')
-rw-r--r--configure.ac37
1 files changed, 12 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index dc67682e..2e97ee09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,8 +123,7 @@ case "${host}" in
have_dosish_system=yes
have_w32_system=yes
GPG_DEFAULT='c:\\gnupg\\gpg.exe'
- # XXX Assuan is not supported in this configuration.
- #GPGSM_DEFAULT='c:\\gnupg\\gpgsm.exe'
+ GPGSM_DEFAULT='c:\\gnupg\\gpgsm.exe'
#component_system='COM+'
;;
*)
@@ -467,18 +466,17 @@ AM_CONDITIONAL(RUN_GPGSM_TESTS, test "$run_gpgsm_test" = "yes")
# FIXME: Only build if supported.
AM_CONDITIONAL(BUILD_ASSUAN, test "$GPGSM" != "no")
if test "$GPGSM" != "no"; then
- AC_DEFINE(HAVE_ASSUAN_H, ,[Defined if we are building with assuan support.])
+ AC_DEFINE(HAVE_ASSUAN_H, 1,
+ [Defined if we are building with assuan support.])
fi
-# The assuan code uses funopen but it will also build without it. So
-# test for it. Frankly, this is not required in gpgme, but thats the
-# way we handle it in libassuan.
+# Check for funopen
AC_CHECK_FUNCS(funopen)
if test $ac_cv_func_funopen != yes; then
# No funopen but we can implement that in terms of fopencookie.
AC_CHECK_FUNCS(fopencookie)
if test $ac_cv_func_fopencookie = yes; then
- AC_LIBOBJ([funopen])
+ AC_REPLACE_FUNCS(funopen)
else
AC_MSG_WARN([
***
@@ -529,13 +527,10 @@ if test "$supports_descriptor_passing" != "yes"; then
fi
if test "$use_descriptor_passing" = "yes"; then
- fd_passing=1
-else
- fd_passing=0
+AC_DEFINE(USE_DESCRIPTOR_PASSING,1,
+ [Defined if descriptor passing is enabled and supported])
fi
-AC_DEFINE_UNQUOTED(USE_DESCRIPTOR_PASSING, $fd_passing,
- [Defined if descriptor passing is enabled and supported])
AM_CONDITIONAL(USE_DESCRIPTOR_PASSING, test "$use_descriptor_passing" = "yes")
# Assuan check for the getsockopt SO_PEERCRED
@@ -554,6 +549,10 @@ if test $assuan_cv_sys_so_peercred = yes; then
[Defined if SO_PEERCRED is supported (Linux specific)])
fi
+if test "$have_w32_system" = yes; then
+ NETLIBS="-lws2_32 $NETLIBS"
+fi
+
# End of assuan checks.
AM_CONDITIONAL(BUILD_COMPLUS, test "$component_system" = "COM+")
@@ -581,23 +580,11 @@ AC_SUBST(BUILD_FILEVERSION)
# Add a few constants to help porting to W32
AH_VERBATIM([SEPCONSTANTS],
[
-/* Separators as used in file names and $PATH. Please note that the
- string version must not contain more than one character because
- the using code assumes strlen()==1 */
+/* Separators as used in $PATH. */
#ifdef HAVE_DOSISH_SYSTEM
-#define DIRSEP_C '\\\\'
-#define EXTSEP_C '.'
-#define DIRSEP_S "\\\\"
-#define EXTSEP_S "."
#define PATHSEP_C ';'
-#define PATHSEP_S ";"
#else
-#define DIRSEP_C '/'
-#define EXTSEP_C '.'
-#define DIRSEP_S "/"
-#define EXTSEP_S "."
#define PATHSEP_C ':'
-#define PATHSEP_S ":"
#endif
])