aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2007-07-04 20:02:38 +0000
committerMarcus Brinkmann <[email protected]>2007-07-04 20:02:38 +0000
commit1639030a88ed2e9428d8943d1a11f57dff8b8bfb (patch)
treefeb26e5f60d32ceca44cadb0f53eb6e824272ecf /configure.ac
parentAdded target "online". (diff)
downloadgpgme-1639030a88ed2e9428d8943d1a11f57dff8b8bfb.tar.gz
gpgme-1639030a88ed2e9428d8943d1a11f57dff8b8bfb.zip
2007-07-04 Marcus Brinkmann <[email protected]>
* autogen.sh: Use = not == in test.
Diffstat (limited to '')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d4f7f7ef..dc67682e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -538,6 +538,22 @@ AC_DEFINE_UNQUOTED(USE_DESCRIPTOR_PASSING, $fd_passing,
[Defined if descriptor passing is enabled and supported])
AM_CONDITIONAL(USE_DESCRIPTOR_PASSING, test "$use_descriptor_passing" = "yes")
+# Assuan check for the getsockopt SO_PEERCRED
+AC_MSG_CHECKING(for SO_PEERCRED)
+AC_CACHE_VAL(assuan_cv_sys_so_peercred,
+ [AC_TRY_COMPILE([#include <sys/socket.h>],
+ [struct ucred cr;
+ int cl = sizeof cr;
+ getsockopt (1, SOL_SOCKET, SO_PEERCRED, &cr, &cl);],
+ assuan_cv_sys_so_peercred=yes,
+ assuan_cv_sys_so_peercred=no)
+ ])
+AC_MSG_RESULT($assuan_cv_sys_so_peercred)
+if test $assuan_cv_sys_so_peercred = yes; then
+ AC_DEFINE(HAVE_SO_PEERCRED, 1,
+ [Defined if SO_PEERCRED is supported (Linux specific)])
+fi
+
# End of assuan checks.
AM_CONDITIONAL(BUILD_COMPLUS, test "$component_system" = "COM+")