aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-09-20 17:43:49 +0000
committerWerner Koch <[email protected]>2016-09-20 17:43:49 +0000
commitdf7e92b4d585b7dce919c5a3aab9524f6e183cbe (patch)
treec676caba16a5dad2b26e9403f27713dc37628799 /Makefile.am
parentpython: Fix detection of Python available versions. (diff)
downloadgpgme-df7e92b4d585b7dce919c5a3aab9524f6e183cbe.tar.gz
gpgme-df7e92b4d585b7dce919c5a3aab9524f6e183cbe.zip
build: Create swdb file.
* Makefile.am (distcheck-hook): New. (dist-hook): s/VERSION/PACKAGE_VERSION/ for future compatibility. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cb22a917..72b8ee95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,9 +39,23 @@ SUBDIRS = src ${tests} doc lang
# to be used for patch's Prereq: feature.
dist-hook: gen-ChangeLog
@set -e; \
- sed -e 's/@pkg_version@/$(VERSION)/g' \
+ sed -e 's/@pkg_version@/$(PACKAGE_VERSION)/g' \
$(top_srcdir)/gpgme.spec.in > $(distdir)/gpgme.spec
- echo "$(VERSION)" > $(distdir)/VERSION
+ echo "$(PACKAGE_VERSION)" > $(distdir)/VERSION
+
+distcheck-hook:
+ set -e; ( \
+ pref="#+macro: gpgme_" ;\
+ reldate="$$(date -u +%Y-%m-%d)" ;\
+ echo "$${pref}ver $(PACKAGE_VERSION)" ;\
+ echo "$${pref}date $${reldate}" ;\
+ list='$(DIST_ARCHIVES)'; for i in $$list; do \
+ case "$$i" in *.tar.bz2) \
+ echo "$${pref}size $$(wc -c <$$i|awk '{print int($$1/1024)}')k" ;\
+ echo "$${pref}sha1 $$(sha1sum <$$i|cut -d' ' -f1)" ;\
+ echo "$${pref}sha2 $$(sha256sum <$$i|cut -d' ' -f1)" ;;\
+ esac;\
+ done ) | tee $(distdir).swdb
gen_start_date = 2011-12-01T00:00:00