aboutsummaryrefslogtreecommitdiffstats
path: root/util
diff options
context:
space:
mode:
Diffstat (limited to 'util')
-rw-r--r--util/ChangeLog4
-rw-r--r--util/Makefile.in20
-rw-r--r--util/strgutil.c12
3 files changed, 36 insertions, 0 deletions
diff --git a/util/ChangeLog b/util/ChangeLog
index 05214578f..89eedb0c1 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,3 +1,7 @@
+Mon Apr 27 11:01:32 1998 Werner Koch ([email protected])
+
+ * strgutil.c (memicmp): New.
+
Thu Mar 19 11:29:03 1998 Werner Koch ([email protected])
* strgutil.c (memistr): Add const to return and first arg.
diff --git a/util/Makefile.in b/util/Makefile.in
index 5f72e6533..025ea3f8e 100644
--- a/util/Makefile.in
+++ b/util/Makefile.in
@@ -61,16 +61,36 @@ host_alias = @host_alias@
host_triplet = @host@
target_alias = @target_alias@
target_triplet = @target@
+CATALOGS = @CATALOGS@
+CATOBJEXT = @CATOBJEXT@
CC = @CC@
CIPHER_EXTRA_DIST = @CIPHER_EXTRA_DIST@
CIPHER_EXTRA_OBJS = @CIPHER_EXTRA_OBJS@
CPP = @CPP@
+DATADIRNAME = @DATADIRNAME@
G10_LOCALEDIR = @G10_LOCALEDIR@
+GENCAT = @GENCAT@
+GMOFILES = @GMOFILES@
+GMSGFMT = @GMSGFMT@
+GT_NO = @GT_NO@
+GT_YES = @GT_YES@
+INCLUDE_LOCALE_H = @INCLUDE_LOCALE_H@
+INSTOBJEXT = @INSTOBJEXT@
+INTLDEPS = @INTLDEPS@
+INTLLIBS = @INTLLIBS@
+INTLOBJS = @INTLOBJS@
+MKINSTALLDIRS = @MKINSTALLDIRS@
MPI_EXTRA_ASM_OBJS = @MPI_EXTRA_ASM_OBJS@
+MSGFMT = @MSGFMT@
PACKAGE = @PACKAGE@
+POFILES = @POFILES@
+POSUB = @POSUB@
RANLIB = @RANLIB@
+USE_INCLUDED_LIBINTL = @USE_INCLUDED_LIBINTL@
+USE_NLS = @USE_NLS@
VERSION = @VERSION@
ZLIBS = @ZLIBS@
+l = @l@
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl -I../intl
diff --git a/util/strgutil.c b/util/strgutil.c
index 3e5999d43..c6c8f5a65 100644
--- a/util/strgutil.c
+++ b/util/strgutil.c
@@ -72,6 +72,18 @@ strlist_last( STRLIST node )
}
+
+
+int
+memicmp( const char *a, const char *b, size_t n )
+{
+ for( ; n; n--, a++, b++ )
+ if( *a != *b && toupper(*(const byte*)a) != toupper(*(const byte*)b) )
+ return *(const byte *)a - *(const byte*)b;
+ return 0;
+}
+
+
/****************
* look for the substring SUB in buffer and return a pointer to that
* substring in BUF or NULL if not found.