aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/ChangeLog5
-rw-r--r--tools/gpgconf-comp.c6
2 files changed, 11 insertions, 0 deletions
diff --git a/tools/ChangeLog b/tools/ChangeLog
index 34e985947..38b9e9cf4 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,8 @@
+2004-12-21 Werner Koch <[email protected]>
+
+ * gpgconf-comp.c (get_config_pathname) [DOSISH]: Detect absolute
+ pathnames with a drive letter.
+
2004-12-15 Werner Koch <[email protected]>
* Makefile.am (bin_PROGRAMS) [W32]: Do not build watchgnupg.
diff --git a/tools/gpgconf-comp.c b/tools/gpgconf-comp.c
index fe696301c..e4758c1e6 100644
--- a/tools/gpgconf-comp.c
+++ b/tools/gpgconf-comp.c
@@ -1272,7 +1272,13 @@ get_config_pathname (gc_component_t component, gc_backend_t backend)
else
pathname = "";
+#ifdef HAVE_DOSISH_SYSTEM
+ if (!(pathname[0]
+ && pathname[1] == ':'
+ && (pathname[2] == '/' || pathname[2] == '\\')))
+#else
if (pathname[0] != '/')
+#endif
gc_error (1, 0, "Option %s, needed by backend %s, is not absolute",
gc_backend[backend].option_config_filename,
gc_backend[backend].name);