aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/ChangeLog11
-rw-r--r--tools/Makefile.am5
-rw-r--r--tools/gpg-connect-agent.c15
-rw-r--r--tools/gpgconf-comp.c7
-rw-r--r--tools/gpgconf.c16
-rw-r--r--tools/symcryptrun.c15
6 files changed, 19 insertions, 50 deletions
diff --git a/tools/ChangeLog b/tools/ChangeLog
index 6ee23ccc5..a75a2b963 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,14 @@
+2007-06-06 Werner Koch <[email protected]>
+
+ * Makefile.am (bin_PROGRAMS) [W32]: Do not build gpgparsemail.
+
+ * gpgconf-comp.c [W32]: Do not include pwd.h and grp.h.
+ (key_matches_user_or_group) [W32]: For now always return false.
+
+ * symcryptrun.c (i18n_init): Remove.
+ * gpgconf.c (i18n_init): Remove.
+ * gpg-connect-agent.c (i18n_init): Remove.
+
2007-05-19 Marcus Brinkmann <[email protected]>
* symcryptrun.c (confucius_get_pass): Free ORIG_CODESET on error.
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 8bd20c5a3..5728c4ff9 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -43,10 +43,9 @@ else
symcryptrun =
endif
-bin_PROGRAMS = gpgconf gpg-connect-agent gpgkey2ssh ${symcryptrun} \
- gpgparsemail
+bin_PROGRAMS = gpgconf gpg-connect-agent gpgkey2ssh ${symcryptrun}
if !HAVE_W32_SYSTEM
-bin_PROGRAMS += watchgnupg
+bin_PROGRAMS += watchgnupg gpgparsemail
endif
noinst_PROGRAMS = clean-sat mk-tdata make-dns-cert gpgsplit
diff --git a/tools/gpg-connect-agent.c b/tools/gpg-connect-agent.c
index 98a13de11..219d7d01f 100644
--- a/tools/gpg-connect-agent.c
+++ b/tools/gpg-connect-agent.c
@@ -142,21 +142,6 @@ my_strusage( int level )
}
-/* Initialize the gettext system. */
-static void
-i18n_init(void)
-{
-#ifdef USE_SIMPLE_GETTEXT
- set_gettext_file (PACKAGE_GT);
-#else
-# ifdef ENABLE_NLS
- setlocale (LC_ALL, "" );
- bindtextdomain (PACKAGE_GT, LOCALEDIR);
- textdomain (PACKAGE_GT);
-# endif
-#endif
-}
-
/* Store an inquire response pattern. Note, that this function may
change the content of LINE. We assume that leading white spaces
are already removed. */
diff --git a/tools/gpgconf-comp.c b/tools/gpgconf-comp.c
index 580972aef..16fa3ad1a 100644
--- a/tools/gpgconf-comp.c
+++ b/tools/gpgconf-comp.c
@@ -33,8 +33,10 @@
#include <time.h>
#include <stdarg.h>
#include <signal.h>
+#ifndef HAVE_W32_SYSTEM
#include <pwd.h>
#include <grp.h>
+#endif
/* For log_logv(), asctimestamp(), gnupg_get_time (). */
#define JNLIB_NEED_LOG_LOGV
@@ -2574,6 +2576,9 @@ gc_component_change_options (int component, FILE *in)
static int
key_matches_user_or_group (char *user)
{
+#ifdef HAVE_W32_SYSTEM
+# warning We need a real user and group lookup.
+#else
char *group;
int n;
@@ -2641,7 +2646,7 @@ key_matches_user_or_group (char *user)
if (!strcmp (group, my_supgroups[n]))
return 1; /* Found. */
}
-
+#endif
return 0; /* No match. */
}
diff --git a/tools/gpgconf.c b/tools/gpgconf.c
index 6d73e88e0..c06db5225 100644
--- a/tools/gpgconf.c
+++ b/tools/gpgconf.c
@@ -104,22 +104,6 @@ my_strusage( int level )
}
-/* Initialize the gettext system. */
-static void
-i18n_init(void)
-{
-#ifdef USE_SIMPLE_GETTEXT
- set_gettext_file (PACKAGE_GT);
-#else
-# ifdef ENABLE_NLS
- setlocale (LC_ALL, "" );
- bindtextdomain (PACKAGE_GT, LOCALEDIR);
- textdomain (PACKAGE_GT);
-# endif
-#endif
-}
-
-
/* gpgconf main. */
int
main (int argc, char **argv)
diff --git a/tools/symcryptrun.c b/tools/symcryptrun.c
index 119121208..f8de30fd9 100644
--- a/tools/symcryptrun.c
+++ b/tools/symcryptrun.c
@@ -223,21 +223,6 @@ my_strusage (int level)
}
-/* Initialize the gettext system. */
-static void
-i18n_init(void)
-{
-#ifdef USE_SIMPLE_GETTEXT
- set_gettext_file (PACKAGE_GT);
-#else
-# ifdef ENABLE_NLS
- setlocale (LC_ALL, "");
- bindtextdomain (PACKAGE_GT, LOCALEDIR);
- textdomain (PACKAGE_GT);
-# endif
-#endif
-}
-
/* This is in the GNU C library in unistd.h. */