aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am2
-rw-r--r--tests/pkits/common.sh2
-rwxr-xr-xtests/pkits/inittests4
3 files changed, 4 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index bb75c97be..7cbf9e8e6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,7 +18,7 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = gpgscm openpgp migrations gpgsm gpgme pkits .
+SUBDIRS = gpgscm openpgp migrations gpgsm gpgme .
GPGSM = ../sm/gpgsm
diff --git a/tests/pkits/common.sh b/tests/pkits/common.sh
index ca18b9501..697f28f67 100644
--- a/tests/pkits/common.sh
+++ b/tests/pkits/common.sh
@@ -52,7 +52,7 @@ if [ -n "$GPG_AGENT_INFO" ]; then
exit 1
fi
-if [ -f PKITS_data.tar.bz2 ]; then
+if [ -f "$srcdir/PKITS_data.tar.bz2" ]; then
:
else
if [ "$pgmname" = "import-all-certs" ]; then
diff --git a/tests/pkits/inittests b/tests/pkits/inittests
index 5c29bdc49..4bff0a8b8 100755
--- a/tests/pkits/inittests
+++ b/tests/pkits/inittests
@@ -58,8 +58,8 @@ if [ -n "$GPG_AGENT_INFO" ]; then
exit 1
fi
-if test -f PKITS_data.tar.bz2; then
- if ! bunzip2 -c PKITS_data.tar.bz2 | tar xf - ; then
+if test -f "$srcdir/PKITS_data.tar.bz2"; then
+ if ! bunzip2 -c "$srcdir/PKITS_data.tar.bz2" | tar xf - ; then
echo "inittests: failed to untar the test data" >&2
exit 1
fi