aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/ChangeLog4
-rw-r--r--tests/Makefile.am8
-rw-r--r--tests/openpgp/ChangeLog4
-rwxr-xr-xtests/openpgp/clearsig.test4
4 files changed, 17 insertions, 3 deletions
diff --git a/tests/ChangeLog b/tests/ChangeLog
index c06cfdca6..305303776 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,7 @@
+2008-09-29 Werner Koch <[email protected]>
+
+ * Makefile.am (TESTS): Remove tests.
+
2008-02-19 Werner Koch <[email protected]>
* Makefile.am: Always run pkits tests.
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2dc94f3c1..01013e0d8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,7 +44,13 @@ EXTRA_DIST = runtest inittests $(testscripts) \
samplekeys/cert_g10code_test1.pem \
samplekeys/cert_g10code_theo1.pem
-TESTS = $(testscripts)
+# We used to run $(testscripts) here but tehse asschk scripts ares not
+# completely reliable in all enviromnets and thus we better disable
+# them. The tests are anyway way to minimal. We will eventually
+# write new tests based on gpg-connect-agent which has a full fledged
+# script language and thus makes it far easier to write tests than to
+# use the low--level asschk stuff.
+TESTS =
CLEANFILES = inittests.stamp x y y z out err \
*.lock .\#lk*
diff --git a/tests/openpgp/ChangeLog b/tests/openpgp/ChangeLog
index 4ce7b9fc0..118e03a79 100644
--- a/tests/openpgp/ChangeLog
+++ b/tests/openpgp/ChangeLog
@@ -1,3 +1,7 @@
+2008-09-29 Werner Koch <[email protected]>
+
+ * clearsig.test: Replace -sat by --clearsign.
+
2008-03-19 Werner Koch <[email protected]>
* import.test, bug894-test.asc: New.
diff --git a/tests/openpgp/clearsig.test b/tests/openpgp/clearsig.test
index 78f1fa6a9..74631e180 100755
--- a/tests/openpgp/clearsig.test
+++ b/tests/openpgp/clearsig.test
@@ -18,7 +18,7 @@
# it is clear text and not binary text.
# ======================================
for i in $plain_files plain-large ; do
- echo "$usrpass1" | $GPG --passphrase-fd 0 -sat -o x --yes $i
+ echo "$usrpass1" | $GPG --passphrase-fd 0 --clearsign -o x --yes $i
$GPG --verify x
done
@@ -29,7 +29,7 @@ done
if have_pubkey_algo "RSA"; then
for i in $plain_files plain-large ; do
- $GPG -u $usrname3 --rfc1991 --digest-algo md5 -sat -o x --yes $i
+ $GPG -u $usrname3 --rfc1991 --digest-algo md5 --clearsign -o x --yes $i
$GPG --verify x
done
fi