aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/ChangeLog5
-rw-r--r--tests/Makefile.am16
2 files changed, 20 insertions, 1 deletions
diff --git a/tests/ChangeLog b/tests/ChangeLog
index 627d02274..bfada39b0 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,8 @@
+2002-09-03 Neal H. Walfield <[email protected]>
+
+ * Makefile.am (inittests.stamp): Construct an LD_LIBRARY_PATH from
+ LDFLAGS.
+
2002-08-09 Werner Koch <[email protected]>
* asschk.c (cmd_getenv): New.
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 442d86435..960b14bc2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -53,6 +53,20 @@ clean-local:
srcdir=$(srcdir) $(TESTS_ENVIRONMENT) $(srcdir)/inittests --clean
inittests.stamp: inittests
- srcdir=$(srcdir) $(TESTS_ENVIRONMENT) $(srcdir)/inittests
+ LD_LIBRARY_PATH=$$(seen=0; \
+ for i in $(LDFLAGS); \
+ do \
+ if echo "$$i" | egrep '^-L' >/dev/null 2>&1; \
+ then \
+ if test $$seen = 0; \
+ then \
+ seen=1; \
+ else \
+ echo -n ":"; \
+ fi; \
+ echo -n $${i} | sed 's/^-L//'; \
+ fi; \
+ done) \
+ srcdir=$(srcdir) $(TESTS_ENVIRONMENT) $(srcdir)/inittests
echo timestamp >./inittests.stamp