aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/ChangeLog3
-rw-r--r--scripts/conf-riscos/cipher/construct.c38
-rw-r--r--scripts/conf-riscos/cipher/constructv.c32
3 files changed, 1 insertions, 72 deletions
diff --git a/scripts/ChangeLog b/scripts/ChangeLog
index 41145b026..13b2a7143 100644
--- a/scripts/ChangeLog
+++ b/scripts/ChangeLog
@@ -1,11 +1,10 @@
2002-08-03 Stefan Bellon <[email protected]>
* conf-riscos/include/g10defs.h: Added GNUPG_LIBEXECDIR.
-
* conf-riscos/include/config.h: Changes due to dynload removal and
minor changes to avoid some warnings.
-
* conf-riscos/Makefile: Changes due to dynload removal.
+ * conf-riscos/cipher/*: Not needed anymore due to dynload removal.
2002-07-25 David Shaw <[email protected]>
diff --git a/scripts/conf-riscos/cipher/construct.c b/scripts/conf-riscos/cipher/construct.c
deleted file mode 100644
index 122d740e8..000000000
--- a/scripts/conf-riscos/cipher/construct.c
+++ /dev/null
@@ -1,38 +0,0 @@
-/* construct.c - RISC OS constructors for cipher algorithms
- * Copyright (C) 2001 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-void rndriscos_constructor(void);
-void sha1_constructor(void);
-void rmd160_constructor(void);
-void md5_constructor(void);
-
-void
-cipher_modules_constructor(void)
-{
- static int done = 0;
- if( done )
- return;
- done = 1;
-
- rndriscos_constructor();
- sha1_constructor();
- rmd160_constructor();
- md5_constructor();
-}
diff --git a/scripts/conf-riscos/cipher/constructv.c b/scripts/conf-riscos/cipher/constructv.c
deleted file mode 100644
index cb50bfff8..000000000
--- a/scripts/conf-riscos/cipher/constructv.c
+++ /dev/null
@@ -1,32 +0,0 @@
-/* constructv.c - RISC OS constructors for cipher algorithms (gpgv version)
- * Copyright (C) 2001 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-void rmd160_constructor(void);
-
-void
-cipher_modules_constructor(void)
-{
- static int done = 0;
- if( done )
- return;
- done = 1;
-
- rmd160_constructor();
-}