aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/autogen.sh
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/autogen.sh')
-rwxr-xr-xscripts/autogen.sh127
1 files changed, 64 insertions, 63 deletions
diff --git a/scripts/autogen.sh b/scripts/autogen.sh
index 24ba3eae6..70635da3a 100755
--- a/scripts/autogen.sh
+++ b/scripts/autogen.sh
@@ -11,17 +11,32 @@
# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-PGM=GnuPG
-lib_config_files=""
-autoconf_vers=2.57
-automake_vers=1.7
-aclocal_vers=1.7
-
-ACLOCAL=${ACLOCAL:-aclocal}
-AUTOCONF=${AUTOCONF:-autoconf}
-AUTOMAKE=${AUTOMAKE:-automake}
-AUTOHEADER=${AUTOHEADER:-autoheader}
-DIE=no
+configure_ac="configure.ac"
+
+cvtver () {
+ awk 'NR==1 {split($NF,A,".");X=1000000*A[1]+1000*A[2]+A[3];print X;exit 0}'
+}
+
+check_version () {
+ if [ `("$1" --version || echo "0") | cvtver` -ge "$2" ]; then
+ return 0
+ fi
+ echo "**Error**: "\`$1\'" not installed or too old." >&2
+ echo ' Version '$3' or newer is required.' >&2
+ [ -n "$4" ] && echo ' Note that this is part of '\`$4\''.' >&2
+ DIE="yes"
+ return 1
+}
+
+# Allow to override the default tool names
+AUTOCONF=${AUTOCONF_PREFIX}${AUTOCONF:-autoconf}${AUTOCONF_SUFFIX}
+AUTOHEADER=${AUTOCONF_PREFIX}${AUTOHEADER:-autoheader}${AUTOCONF_SUFFIX}
+
+AUTOMAKE=${AUTOMAKE_PREFIX}${AUTOMAKE:-automake}${AUTOMAKE_SUFFIX}
+ACLOCAL=${AUTOMAKE_PREFIX}${ACLOCAL:-aclocal}${AUTOMAKE_SUFFIX}
+
+GETTEXT=${GETTEXT_PREFIX}${GETTEXT:-gettext}${GETTEXT_SUFFIX}
+MSGMERGE=${GETTEXT_PREFIX}${MSGMERGE:-msgmerge}${GETTEXT_SUFFIX}
# Used to cross-compile GnuPG for Windows.
if test "$1" = "--build-w32"; then
@@ -194,67 +209,54 @@ if test "$1" = "--build-uclinux"; then
fi
+# Grep the required versions from configure.ac
+autoconf_vers=`sed -n '/^AC_PREREQ(/ {
+s/^.*(\(.*\))/\1/p
+q
+}' ${configure_ac}`
+autoconf_vers_num=`echo "$autoconf_vers" | cvtver`
-if ($AUTOCONF --version) < /dev/null > /dev/null 2>&1 ; then
- if ($AUTOCONF --version | awk 'NR==1 { if( $3 >= '$autoconf_vers') \
- exit 1; exit 0; }');
- then
- echo "**Error**: "\`autoconf\'" is too old."
- echo ' (version ' $autoconf_vers ' or newer is required)'
- DIE="yes"
- fi
-else
- echo
- echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
- echo ' (version ' $autoconf_vers ' or newer is required)'
- DIE="yes"
-fi
+automake_vers=`sed -n '/^min_automake_version=/ {
+s/^.*="\(.*\)"/\1/p
+q
+}' ${configure_ac}`
+automake_vers_num=`echo "$automake_vers" | cvtver`
-if ($AUTOMAKE --version) < /dev/null > /dev/null 2>&1 ; then
- if ($AUTOMAKE --version | awk 'NR==1 { if( $4 >= '$automake_vers') \
- exit 1; exit 0; }');
- then
- echo "**Error**: "\`automake\'" is too old."
- echo ' (version ' $automake_vers ' or newer is required)'
- DIE="yes"
- fi
- if ($ACLOCAL --version) < /dev/null > /dev/null 2>&1; then
- if ($ACLOCAL --version | awk 'NR==1 { if( $4 >= '$aclocal_vers' ) \
- exit 1; exit 0; }' );
- then
- echo "**Error**: "\`aclocal\'" is too old."
- echo ' (version ' $aclocal_vers ' or newer is required)'
- DIE="yes"
- fi
- else
- echo
- echo "**Error**: Missing "\`aclocal\'". The version of "\`automake\'
- echo " installed doesn't appear recent enough."
- DIE="yes"
- fi
-else
- echo
- echo "**Error**: You must have "\`automake\'" installed to compile $PGM."
- echo ' (version ' $automake_vers ' or newer is required)'
- DIE="yes"
-fi
+gettext_vers=`sed -n '/^AM_GNU_GETTEXT_VERSION(/ {
+s/^.*(\(.*\))/\1/p
+q
+}' ${configure_ac}`
+gettext_vers_num=`echo "$gettext_vers" | cvtver`
-if (gettext --version </dev/null 2>/dev/null | awk 'NR==1 { split($4,A,"."); \
- X=10000*A[1]+100*A[2]+A[3]; echo X; if( X >= 1201 ) exit 1; exit 0}')
- then
- echo "**Error**: You must have "\`gettext\'" installed to compile $PGM."
- echo ' (version 0.12.1 or newer is required; get'
- echo ' ftp://alpha.gnu.org/gnu/gettext/gettext-0.12.1.tar.gz'
- echo ' or install the latest Debian package)'
- DIE="yes"
+if [ -z "$autoconf_vers" -o -z "$automake_vers" -o -z "$gettext_vers" ]
+then
+ echo "**Error**: version information not found in "\`${configure_ac}\'"." >&2
+ exit 1
fi
+if check_version $AUTOCONF $autoconf_vers_num $autoconf_vers ; then
+ check_version $AUTOHEADER $autoconf_vers_num $autoconf_vers autoconf
+fi
+if check_version $AUTOMAKE $automake_vers_num $automake_vers; then
+ check_version $ACLOCAL $automake_vers_num $autoconf_vers automake
+fi
+if check_version $GETTEXT $gettext_vers_num $gettext_vers; then
+ check_version $MSGMERGE $gettext_vers_num $gettext_vers gettext
+fi
+
if test "$DIE" = "yes"; then
+ cat <<EOF
+
+Note that you may use alternative versions of the tools by setting
+the corresponding environment variables; see README.CVS for details.
+
+EOF
exit 1
fi
+
echo "Running aclocal -I m4 ${ACLOCAL_FLAGS:+$ACLOCAL_FLAGS }..."
$ACLOCAL -I m4 $ACLOCAL_FLAGS
echo "Running autoheader..."
@@ -264,5 +266,4 @@ $AUTOMAKE --gnu;
echo "Running autoconf..."
$AUTOCONF
-echo "You can now run \"./configure --enable-maintainer-mode\" and then \"make\"."
-
+echo "You may now run \"./configure --enable-maintainer-mode && make\"."