aboutsummaryrefslogtreecommitdiffstats
path: root/scd
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scd/ChangeLog6
-rw-r--r--scd/apdu.c1
2 files changed, 7 insertions, 0 deletions
diff --git a/scd/ChangeLog b/scd/ChangeLog
index cb759c0b2..b0f07dc82 100644
--- a/scd/ChangeLog
+++ b/scd/ChangeLog
@@ -1,3 +1,9 @@
+2004-07-27 Moritz Schulte <[email protected]>
+
+ * apdu.c: Include <signal.h>.
+
+ * Makefile.am: Use @DL_LIBS@ instead of -ldl.
+
2004-07-22 Werner Koch <[email protected]>
* Makefile.am: Make OpenSC lib link after libgcrypt. Do not link
diff --git a/scd/apdu.c b/scd/apdu.c
index 28d32ad2c..7898452c4 100644
--- a/scd/apdu.c
+++ b/scd/apdu.c
@@ -25,6 +25,7 @@
#include <stdlib.h>
#include <string.h>
#include <assert.h>
+#include <signal.h>
#ifdef USE_GNU_PTH
# include <pth.h>
# include <unistd.h>