aboutsummaryrefslogtreecommitdiffstats
path: root/kbx
diff options
context:
space:
mode:
Diffstat (limited to 'kbx')
-rw-r--r--kbx/ChangeLog5
-rw-r--r--kbx/keybox-openpgp.c4
2 files changed, 7 insertions, 2 deletions
diff --git a/kbx/ChangeLog b/kbx/ChangeLog
index 14b702318..a7202a69e 100644
--- a/kbx/ChangeLog
+++ b/kbx/ChangeLog
@@ -1,3 +1,8 @@
+2006-09-14 Werner Koch <[email protected]>
+
+ Replaced all call gpg_error_from_errno(errno) by
+ gpg_error_from_syserror().
+
2005-10-08 Marcus Brinkmann <[email protected]>
* Makefile.am (kbxutil_LDADD): Add ../gl/libgnu.a after
diff --git a/kbx/keybox-openpgp.c b/kbx/keybox-openpgp.c
index 8ac713979..dea0047ca 100644
--- a/kbx/keybox-openpgp.c
+++ b/kbx/keybox-openpgp.c
@@ -405,7 +405,7 @@ _keybox_parse_openpgp (const unsigned char *image, size_t imagelen,
u = xtrycalloc (1, sizeof *u);
if (!u)
{
- err = gpg_error_from_errno (errno);
+ err = gpg_error_from_syserror ();
break;
}
u->off = data - image_start;
@@ -447,7 +447,7 @@ _keybox_parse_openpgp (const unsigned char *image, size_t imagelen,
k = xtrycalloc (1, sizeof *k);
if (!k)
{
- err = gpg_error_from_errno (errno);
+ err = gpg_error_from_syserror ();
break;
}
err = parse_key (data, datalen, k);