aboutsummaryrefslogtreecommitdiffstats
path: root/kbx
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--kbx/ChangeLog11
-rw-r--r--kbx/Makefile.am4
-rw-r--r--kbx/keybox-search.c5
3 files changed, 14 insertions, 6 deletions
diff --git a/kbx/ChangeLog b/kbx/ChangeLog
index 351ec5d13..14c225fea 100644
--- a/kbx/ChangeLog
+++ b/kbx/ChangeLog
@@ -1,3 +1,12 @@
+2002-11-14 Werner Koch <[email protected]>
+
+ * keybox-search.c (blob_cmp_name) <compare all names>: Fixed
+ length compare; there is no 0 stored since nearly a year.
+
+2002-10-31 Neal H. Walfield <[email protected]>
+
+ * Makefile.am (AM_CPPFLAGS): Fix ytpo.
+
2002-08-10 Werner Koch <[email protected]>
* keybox-search.c (blob_cmp_fpr_part): New.
@@ -16,7 +25,7 @@
2002-06-19 Werner Koch <[email protected]>
* keybox-init.c (keybox_set_ephemeral): New.
- * keybox-blob.c (create_blob_header): Store epheermal flag.
+ * keybox-blob.c (create_blob_header): Store ephemeral flag.
(_keybox_create_x509_blob): Pass epheermal flag on.
* keybox-update.c (keybox_insert_cert): Ditto.
* keybox-search.c (blob_get_blob_flags): New.
diff --git a/kbx/Makefile.am b/kbx/Makefile.am
index 4e7170379..78d5df26d 100644
--- a/kbx/Makefile.am
+++ b/kbx/Makefile.am
@@ -1,5 +1,5 @@
# Keybox Makefile
-# Copyright (C) 2001 Free Software Foundation, Inc.
+# Copyright (C) 2001, 2002 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -23,7 +23,7 @@ localedir = $(datadir)/locale
INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
EXTRA_DIST = mkerrors
-AM_CPPFLAGS = $(KSBA_CFLAGS) $(LIBGCRYPT_CLFAGS)
+AM_CPPFLAGS = $(KSBA_CFLAGS) $(LIBGCRYPT_CFLAGS)
BUILT_SOURCES = keybox-errors.c
noinst_LIBRARIES = libkeybox.a
diff --git a/kbx/keybox-search.c b/kbx/keybox-search.c
index 126364f5b..a96b0c205 100644
--- a/kbx/keybox-search.c
+++ b/kbx/keybox-search.c
@@ -234,9 +234,8 @@ blob_cmp_name (KEYBOXBLOB blob, int idx,
len = get32 (buffer+mypos+4);
if (off+len > length)
return 0; /* error: better stop here out of bounds */
- if (len < 2)
- continue; /* empty name or 0 not stored */
- len--;
+ if (len < 1)
+ continue; /* empty name */
if (substr)
{
if (ascii_memcasemem (buffer+off, len, name, namelen))