aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in421
1 files changed, 0 insertions, 421 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 563e9a4f6..000000000
--- a/configure.in
+++ /dev/null
@@ -1,421 +0,0 @@
-dnl
-dnl Configure template for GNUPG
-dnl
-dnl (Process this file with autoconf to produce a configure script.)
-AC_REVISION($Revision$)dnl
-
-dnl Must reset CDPATH so that bash's cd does not print to stdout
-CDPATH=
-
-AC_PREREQ(2.13)
-AC_INIT(g10/gpg.c)
-AC_CONFIG_AUX_DIR(scripts)
-AM_CONFIG_HEADER(config.h)
-AC_CANONICAL_SYSTEM
-AM_INIT_AUTOMAKE(gnupg,1.1.2a)
-
-ALL_LINGUAS="da de eo es_ES fr id it ja nl pl pt_BR pt_PT ru sv"
-
-AC_PROG_AWK
-
-dnl
-dnl Check other options
-dnl
-
-AC_MSG_CHECKING([whether memory debugging is requested])
-AC_ARG_ENABLE(m-debug,
-[ --enable-m-debug enable debugging of memory allocation],
-use_m_debug=$enableval, use_m_debug=no)
-AC_MSG_RESULT($use_m_debug)
-if test "$use_m_debug" = yes; then
- AC_DEFINE(M_DEBUG)
- use_m_guard=yes
-else
- AC_MSG_CHECKING([whether memory guard is requested])
- AC_ARG_ENABLE(m-guard,
- [ --enable-m-guard enable memory guard facility],
- use_m_guard=$enableval, use_m_guard=no)
- AC_MSG_RESULT($use_m_guard)
-fi
-if test "$use_m_guard" = yes ; then
- AC_DEFINE(M_GUARD)
-fi
-
-
-AC_MSG_CHECKING([whether included zlib is requested])
-AC_ARG_WITH(included-zlib,
- [ --with-included-zlib use the zlib code included here],
-[g10_force_zlib=yes], [g10_force_zlib=no] )
-AC_MSG_RESULT($g10_force_zlib)
-
-dnl
-dnl Check whether we want to use Linux capabilities
-dnl
-AC_MSG_CHECKING([whether use of capabilities is requested])
-AC_ARG_WITH(capabilities,
- [ --with-capabilities use linux capabilities [default=no]],
-[use_capabilities="$withval"],[use_capabilities=no])
-AC_MSG_RESULT($use_capabilities)
-
-
-
-
-
-AM_MAINTAINER_MODE
-
-dnl Checks for programs.
-
-dnl
-dnl Setup some stuff depending on host/target.
-dnl
-case "${target}" in
- *-*-mingw32*)
- # special stuff for Windoze NT
- # Do we need to set cross_compiling here or is it sufficient
- # to rely on AC_PROG_CC which is called later?
- cross_compiling=yes
- CC="${target}-gcc"
- CPP="${target}-gcc -E"
- RANLIB="${target}-ranlib"
- disallowed_modules="rndunix rndlinux rndegd"
- ;;
- *)
- disallowed_modules="rndw32"
- ;;
-esac
-
-AC_ARG_PROGRAM
-AC_PROG_MAKE_SET
-AM_SANITY_CHECK
-missing_dir=`cd $ac_aux_dir && pwd`
-AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
-AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
-AM_MISSING_PROG(AUTOMAKE, automake, $missing_dir)
-AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
-dnl AM_MISSING_PROG(MAKEINFO, makeinfo, $missing_dir)
-AC_PROG_CC
-AC_PROG_CPP
-AC_ISC_POSIX
-AC_PROG_INSTALL
-AC_PROG_AWK
-GPH_PROG_DOCBOOK
-GNUPG_CHECK_FAQPROG
-
-
-try_gettext=yes
-case "${target}" in
- *-*-mingw32*)
- # special stuff for Windoze NT
- ac_cv_have_dev_random=no
- AC_DEFINE(USE_ONLY_8DOT3)
- AC_DEFINE(HAVE_DRIVE_LETTERS)
- AC_DEFINE(HAVE_DOSISH_SYSTEM)
- AC_DEFINE(USE_SIMPLE_GETTEXT)
- try_gettext="no"
- ;;
- i?86-emx-os2 | i?86-*-os2*emx )
- # OS/2 with the EMX environment
- ac_cv_have_dev_random=no
- AC_DEFINE(HAVE_DRIVE_LETTERS)
- AC_DEFINE(HAVE_DOSISH_SYSTEM)
- try_gettext="no"
- ;;
-
- i?86-*-msdosdjgpp*)
- # DOS with the DJGPP environment
- ac_cv_have_dev_random=no
- AC_DEFINE(HAVE_DRIVE_LETTERS)
- AC_DEFINE(HAVE_DOSISH_SYSTEM)
- try_gettext="no"
- ;;
-
- *-*-freebsd*)
- # FreeBSD
- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
- LDFLAGS="$LDFLAGS -L/usr/local/lib"
- ;;
-
- *-*-hpux*)
- if test -z "$GCC" ; then
- CFLAGS="$CFLAGS -Ae -D_HPUX_SOURCE"
- fi
- ;;
- *-dec-osf4*)
- if test -z "$GCC" ; then
- # Suppress all warnings
- # to get rid of the unsigned/signed char mismatch warnings.
- CFLAGS="$CFLAGS -w"
- fi
- ;;
- m68k-atari-mint)
- ;;
- *)
- ;;
-esac
-
-
-case "${target}" in
- *-*-mingw32*)
- PRINTABLE_OS_NAME="MingW32"
- ;;
- i?86-emx-os2 | i?86-*-os2*emx )
- PRINTABLE_OS_NAME="OS/2"
- ;;
- i?86-*-msdosdjgpp*)
- PRINTABLE_OS_NAME="MSDOS/DJGPP"
- ;;
- *-linux*)
- PRINTABLE_OS_NAME="GNU/Linux"
- ;;
-dnl let that after linux to avoid gnu-linux problems
- *-gnu*)
- PRINTABLE_OS_NAME="GNU/Hurd"
- ;;
- *)
- PRINTABLE_OS_NAME=`uname -s || echo "Unknown"`
- ;;
-esac
-AC_DEFINE_UNQUOTED(PRINTABLE_OS_NAME, "$PRINTABLE_OS_NAME")
-
-dnl Checks for libraries.
-
-if test "$try_gettext" = yes; then
-AM_GNU_GETTEXT
-else
-USE_NLS=no
-USE_INCLUDED_LIBINTL=no
-AC_SUBST(USE_NLS)
-AC_SUBST(USE_INCLUDED_LIBINTL)
-fi
-
-AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config)
-if test -n "$LIBGCRYPT_CONFIG"; then
- LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
- LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
-else
- AC_MSG_ERROR([[
-***
-*** You need libgcrypt to build this program.
-*** It should be available at the same place you go this
-*** software.
-***]])
-fi
-AC_SUBST(LIBGCRYPT_CFLAGS)
-AC_SUBST(LIBGCRYPT_LIBS)
-
-
-dnl Where is the GTK+ toolkit
-if test "$cross_compiling" = yes ; then
- CFLAGS="$CFLAGS -I/home/wk/work/gtk+w32/include/gtk+/gdk/win32 \
- -I/home/wk/work/gtk+w32/include -I/home/wk/work/gtk+w32/include/gtk+"
- LIBS="$LIBS -L/home/wk/work/gtk+w32/lib -lgtk -lgdk -lglib"
- compile_agent=no
-else
- AM_PATH_GTK(1.2.1, compile_agent=yes,compile_agent=no)
-fi
-AM_CONDITIONAL(COMPILE_AGENT, test x$compile_agent = xyes)
-
-
-dnl Solaris needs -lsocket and -lnsl. Unisys system includes
-dnl gethostbyname in libsocket but needs libnsl for socket.
-AC_CHECK_LIB(nsl, gethostbyname)
-AC_CHECK_LIB(socket, socket, ac_need_libsocket=1, ac_try_nsl=1)
-if test x$ac_need_libsocket = x1; then
- LIBS="$LIBS -lsocket"
-fi
-if test x$ac_try_nsl = x1; then
- AC_CHECK_LIB(nsl, gethostbyname, ac_need_libnsl=1)
- if test x$ac_need_libnsl = x1
- then
- LIBS="$LIBS -lnsl"
- fi
-fi
-
-
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS(unistd.h langinfo.h termio.h)
-
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_C_INLINE
-AC_TYPE_SIZE_T
-AC_TYPE_SIGNAL
-AC_DECL_SYS_SIGLIST
-
-GNUPG_CHECK_ENDIAN
-
-
-GNUPG_CHECK_TYPEDEF(byte, HAVE_BYTE_TYPEDEF)
-GNUPG_CHECK_TYPEDEF(ushort, HAVE_USHORT_TYPEDEF)
-GNUPG_CHECK_TYPEDEF(ulong, HAVE_ULONG_TYPEDEF)
-GNUPG_CHECK_TYPEDEF(u16, HAVE_U16_TYPEDEF)
-GNUPG_CHECK_TYPEDEF(u32, HAVE_U32_TYPEDEF)
-
-AC_CHECK_SIZEOF(unsigned short, 2)
-AC_CHECK_SIZEOF(unsigned int, 4)
-AC_CHECK_SIZEOF(unsigned long, 4)
-AC_CHECK_SIZEOF(unsigned long long, 0)
-
-if test "$ac_cv_sizeof_unsigned_short" = "0" \
- || test "$ac_cv_sizeof_unsigned_int" = "0" \
- || test "$ac_cv_sizeof_unsigned_long" = "0"; then
- AC_MSG_WARN([Hmmm, something is wrong with the sizes - using defaults]);
-fi
-
-
-
-dnl Checks for library functions.
-AC_FUNC_VPRINTF
-AC_CHECK_FUNCS(strerror stpcpy strlwr stricmp tcgetattr rand strtoul mmap)
-AC_CHECK_FUNCS(memmove gettimeofday getrusage gethrtime setrlimit clock_gettime)
-AC_CHECK_FUNCS(memicmp atexit raise getpagesize strftime nl_langinfo)
-AC_CHECK_FUNCS(waitpid wait4 sigaction sigprocmask fopen64 fstat64)
-
-GNUPG_CHECK_MLOCK
-GNUPG_FUNC_MKDIR_TAKES_ONE_ARG
-
-dnl
-dnl Check whether we can use Linux capabilities as requested
-dnl
-if test "$use_capabilities" = "yes" ; then
-use_capabilities=no
-AC_CHECK_HEADERS(sys/capability.h)
-if test "$ac_cv_header_sys_capability_h" = "yes" ; then
- AC_CHECK_LIB(cap, cap_init, ac_need_libcap=1)
- if test "$ac_cv_lib_cap_cap_init" = "yes"; then
- AC_DEFINE(USE_CAPABILITIES)
- LIBS="$LIBS -lcap"
- use_capabilities=yes
- fi
-fi
-if test "$use_capabilities" = "no" ; then
- AC_MSG_WARN([[
-***
-*** The use of capabilities on this system is not possible.
-*** You need a recent Linux kernel and some patches:
-*** fcaps-2.2.9-990610.patch (kernel patch for 2.2.9)
-*** fcap-module-990613.tar.gz (kernel module)
-*** libcap-1.92.tar.gz (user mode library and utilities)
-*** And you have to configure the kernel with CONFIG_VFS_CAP_PLUGIN
-*** set (filesystems menu). Be warned: This code is *really* ALPHA.
-***]])
-fi
-fi
-
-
-GNUPG_CHECK_IPC
-if test "$ac_cv_header_sys_shm_h" = "yes"; then
- AC_DEFINE(USE_SHM_COPROCESSING)
-fi
-
-
-dnl
-dnl Do we have zlib? Must do it here because Solaris failed
-dnl when compiling a conftest (due to the "-lz" from LIBS).
-dnl
-use_local_zlib=yes
-if test "$g10_force_zlib" = "yes"; then
- :
-else
- AC_CHECK_HEADERS(zlib.h)
- if test "$ac_cv_header_zlib_h" = yes ; then
- AC_CHECK_LIB(z,deflateInit2_,use_local_zlib=no,:)
- fi
-fi
-
-if test "$use_local_zlib" = yes ; then
- AM_CONDITIONAL(ENABLE_LOCAL_ZLIB, true)
- GNUPG_LINK_FILES(zlib/zlib.h, zlib.h )
- GNUPG_LINK_FILES(zlib/zconf.h, zconf.h )
- ZLIBS="../zlib/libzlib.a"
-else
- AM_CONDITIONAL(ENABLE_LOCAL_ZLIB, false)
- ZLIBS=
- LIBS="-lz $LIBS"
-fi
-AC_SUBST(ZLIBS)
-
-
-# Allow users to append something to the version string without
-# flagging it as development version. The user version part is
-# considered everything after a dash.
-changequote(,)dnl
-tmp_pat='[a-zA-Z]'
-changequote([,])dnl
-if echo "$VERSION" | sed 's/-.*//' | grep "$tmp_pat" >/dev/null ; then
- AC_DEFINE(IS_DEVELOPMENT_VERSION)
-fi
-
-dnl Temp workarounds
-GNUPG_LINK_FILES(include/types.h, types.h )
-
-AM_CONDITIONAL(CROSS_COMPILING, test x$cross_compiling = xyes)
-
-GNUPG_DO_LINK_FILES
-
-GNUPG_CHECK_GNUMAKE
-
-if test "$GCC" = yes; then
- if test "$MAINTAINER_MODE" = "yes"; then
- CFLAGS="$CFLAGS -Wall -Wcast-align -Wshadow -Wstrict-prototypes"
- else
- CFLAGS="$CFLAGS -Wall"
- fi
-fi
-
-
-AC_OUTPUT_COMMANDS([
-chmod +x scripts/db2html
-cat >gnupg-defs.tmp <<G10EOF
-/* Generated automatically by configure */
-#ifdef HAVE_DRIVE_LETTERS
- #define GNUPG_LOCALEDIR "c:/lib/gnupg/locale"
- #define GNUPG_LIBDIR "c:/lib/gnupg"
- #define GNUPG_DATADIR "c:/lib/gnupg"
- #define GNUPG_HOMEDIR "c:/gnupg-test"
-#else
- #define GNUPG_LOCALEDIR "${prefix}/${DATADIRNAME}/locale"
- #define GNUPG_LIBDIR "${libdir}/gnupg"
- #define GNUPG_DATADIR "${datadir}/gnupg"
- #ifdef __VMS
- #define GNUPG_HOMEDIR "/SYS\$LOGIN/gnupg"
- #else
- #define GNUPG_HOMEDIR "~/.gnupg-test"
- #endif
-#endif
-G10EOF
-if cmp -s gnupg-defs.h gnupg-defs.tmp 2>/dev/null; then
- echo "gnupg-defs.h is unchanged"
- rm -f gnupg-defs.tmp
-else
- rm -f gnupg-defs.h
- mv gnupg-defs.tmp gnupg-defs.h
- echo "gnupg-defs.h created"
-fi
-],[
-prefix=$prefix
-exec_prefix=$exec_prefix
-libdir=$libdir
-datadir=$datadir
-DATADIRNAME=$DATADIRNAME
-])
-
-
-AC_OUTPUT([
-Makefile
-scripts/db2html
-intl/Makefile
-po/Makefile.in
-jnlib/Makefile
-util/Makefile
-g10/Makefile
-agent/Makefile
-doc/Makefile
-doc/version.sgml
-tools/Makefile
-zlib/Makefile
-checks/Makefile
-])
-