aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b7a4b959..bcc4a41c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,16 @@ if test "$use_m_guard" = yes ; then
AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
fi
+AC_MSG_CHECKING([whether to enable experimental TIGER digest support])
+AC_ARG_ENABLE(tiger,
+ [ --enable-tiger enable experimental TIGER digest support],
+ use_tiger=$enableval, use_tiger=no)
+AC_MSG_RESULT($use_tiger)
+if test "$use_tiger" = yes ; then
+ AC_SUBST(TIGER_O,tiger.o)
+ AC_DEFINE(USE_TIGER,1,[Define to include experimental TIGER digest support])
+fi
+
AC_MSG_CHECKING([whether to enable external program execution])
AC_ARG_ENABLE(exec,
[ --disable-exec disable all external program execution],