aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c8d3229b8..97ae48c33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1115,8 +1115,12 @@ cat >g10defs.tmp <<G10EOF
#define EXTSEP_S "."
#endif
/* This is the same as VERSION, but should be overridden if the
- platform cannot handle things like dots '.' in filenames. */
-#define SAFE_VERSION VERSION
+ platform cannot handle things like dots'.' in filenames. Set
+ SAFE_VERSION_DOT and SAFE_VERSION_DASH to whatever SAFE_VERSION
+ uses for dots and dashes. */
+#define SAFE_VERSION VERSION
+#define SAFE_VERSION_DOT '.'
+#define SAFE_VERSION_DASH '-'
G10EOF
cat mpi/mpi-asm-defs.h >>g10defs.tmp
if cmp -s g10defs.h g10defs.tmp 2>/dev/null; then