aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 50f28e020..a6adfc26a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,16 +109,6 @@ dnl if test "$use_m_guard" = yes ; then
dnl AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
dnl fi
-# We don't have a test to check whether as(1) knows about the
-# non executable stack option. Thus we provide an option to enable
-# it.
-AC_MSG_CHECKING([whether non excutable stack support is requested])
-AC_ARG_ENABLE(noexecstack,
- AC_HELP_STRING([--enable-noexecstack],
- [enable non executable stack support (gcc only)]),
- noexecstack_support=$enableval, noexecstack_support=no)
-AC_MSG_RESULT($noexecstack_support)
-
# SELinux support includes tracking of sensitive files to avoid
# leaking their contents through processing these files by gpg itself
AC_MSG_CHECKING([whether SELinux support is requested])
@@ -1287,16 +1277,9 @@ if test "$GCC" = yes; then
if test x"$_gcc_psign" = xyes ; then
CFLAGS="$CFLAGS -Wno-pointer-sign"
fi
-
- # Non exec stack hack. Fixme: Write a test to check whether as
- # can cope with it and use the enable-noexecstack option only to
- # disable it in case it is required on sime platforms.
- if test "$noexecstack_support" = yes; then
- NOEXECSTACK_FLAGS="-Wa,--noexecstack"
- fi
fi
-AC_SUBST(NOEXECSTACK_FLAGS)
+CL_AS_NOEXECSTACK
if test "$print_egd_warning" = yes; then
AC_MSG_WARN([[