aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4abeeb007..dc4d1ae36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1168,6 +1168,7 @@ AC_DEFINE_UNQUOTED(PRINTABLE_OS_NAME, "$PRINTABLE_OS_NAME",
AM_ICONV
+
#
# Check for gettext
#
@@ -1785,6 +1786,17 @@ if test "$have_npth" = "no"; then
***]])
fi
+if test "$am_func_iconv" != yes; then
+ die=yes
+ AC_MSG_NOTICE([[
+***
+*** The system does not provide a working iconv function. Please
+*** install a suitable library; for example GNU Libiconv which is
+*** available at:
+*** http://ftp.gnu.org/gnu/libiconv/
+***]])
+fi
+
if test "$die" = "yes"; then
AC_MSG_ERROR([[
***