aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--common/ChangeLog5
-rw-r--r--common/Makefile.am8
2 files changed, 9 insertions, 4 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index b4c79e234..281dd64c6 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,8 @@
+2010-08-13 Werner Koch <[email protected]>
+
+ * Makefile.am (audit-events.h, status-codes.h): Fix srcdir problem
+ amd depend on Makefile.am instead of Makefile.
+
2010-08-12 Werner Koch <[email protected]>
* sysutils.c (gnupg_remove) [W32CE]: Fix returned error.
diff --git a/common/Makefile.am b/common/Makefile.am
index 26c8233e4..110fc5f58 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -139,16 +139,16 @@ if MAINTAINER_MODE
# is a distributed built source. If we would not do that we may end
# up with two files and then it is not clear which version of the
# files will be picked up.
-audit-events.h: Makefile mkstrtable.awk exaudit.awk audit.h
+audit-events.h: Makefile.am mkstrtable.awk exaudit.awk audit.h
$(AWK) -f $(srcdir)/exaudit.awk $(srcdir)/audit.h \
| $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=3 -v nogettext=1 \
- -v namespace=eventstr_ > $(srcdir)/$@
+ -v namespace=eventstr_ > $(srcdir)/audit-events.h
# Create the status-codes.h include file from status.h
-status-codes.h: Makefile mkstrtable.awk exstatus.awk status.h
+status-codes.h: Makefile.am mkstrtable.awk exstatus.awk status.h
$(AWK) -f $(srcdir)/exstatus.awk $(srcdir)/status.h \
| $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=3 -v nogettext=1 \
- -v namespace=statusstr_ > $(srcdir)/$@
+ -v namespace=statusstr_ > $(srcdir)/status-codes.h
endif
#