aboutsummaryrefslogtreecommitdiffstats
path: root/cipher
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog4
-rw-r--r--cipher/Makefile.am10
2 files changed, 10 insertions, 4 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index cb6082e34..7b16f1215 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,7 @@
+Mon Sep 7 17:04:33 1998 Werner Koch (wk@(none))
+
+ * Makefile.am: Fixes to allow a different build directory
+
Thu Aug 6 17:25:38 1998 Werner Koch,mobil,,, (wk@tobold)
* random.c (get_random_byte): Removed and changed all callers
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 36dd0c537..a9d5a5cad 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -44,11 +44,13 @@ libcipher_a_SOURCES = cipher.c \
EXTRA_tiger_SOURCES = tiger.c
EXTRA_twofish_SOURCES = twofish.c
-tiger: tiger.c
- $(COMPILE) -shared -fPIC -o tiger tiger.c
-twofish: twofish.c
- $(COMPILE) -shared -fPIC -o twofish twofish.c
+tiger: $(srcdir)/tiger.c
+ $(COMPILE) -shared -fPIC -o tiger $(srcdir)/tiger.c
+
+twofish: $(srcdir)/twofish.c
+ $(COMPILE) -shared -fPIC -o twofish $(srcdir)/twofish.c
+
install-exec-hook:
@list='$(pkglib_PROGRAMS)'; for p in $$list; do \