aboutsummaryrefslogtreecommitdiffstats
path: root/cipher
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cipher/ChangeLog4
-rw-r--r--cipher/Makefile.am5
-rw-r--r--cipher/random.c4
3 files changed, 8 insertions, 5 deletions
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index 877a2ad26..72129a898 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,7 @@
+Mon Jul 17 16:35:47 CEST 2000 Werner Koch <wk@>
+
+ * random.c (gather_faked): Replaced make_timestamp by time(2) again.
+
Fri Jul 14 19:38:23 CEST 2000 Werner Koch <wk@>
* md.c (gcry_md_ctl): Support GCRYCTL_{START,STOP}_DUMP.
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 9792419f5..2ed370f05 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -1,4 +1,4 @@
-## Process this file with automake to produce Makefile.in
+# Process this file with automake to produce Makefile.in
INCLUDES = -I$(top_srcdir)/gcrypt
@@ -56,9 +56,8 @@ libcipher_la_SOURCES = cipher.c \
# configure creates the constructor file
BUILT_SOURCES = construct.c
-
libcipher_la_DEPENDENCIES = @STATIC_CIPHER_OBJS@
-libcipher_la_LIBADD = @STATIC_CIPHER_OBJS@
+libcipher_la_LIBADD = @STATIC_CIPHER_OBJS@
# If I remember it correct, automake 1.4 has a feature to set
diff --git a/cipher/random.c b/cipher/random.c
index f8faeebf0..0258f5dd0 100644
--- a/cipher/random.c
+++ b/cipher/random.c
@@ -666,9 +666,9 @@ gather_faked( void (*add)(const void*, size_t, int), int requester,
#endif
initialized=1;
#ifdef HAVE_RAND
- srand(make_timestamp()*getpid());
+ srand( time(NULL)*getpid());
#else
- srandom(make_timestamp()*getpid());
+ srandom( time(NULL)*getpid());
#endif
}