aboutsummaryrefslogtreecommitdiffstats
path: root/agent
diff options
context:
space:
mode:
Diffstat (limited to 'agent')
-rw-r--r--agent/ChangeLog6
-rw-r--r--agent/Makefile.am3
-rw-r--r--agent/sexp-parse.h99
3 files changed, 6 insertions, 102 deletions
diff --git a/agent/ChangeLog b/agent/ChangeLog
index bd009ecbe..57f9214f6 100644
--- a/agent/ChangeLog
+++ b/agent/ChangeLog
@@ -1,3 +1,7 @@
+2004-01-27 Werner Koch <[email protected]>
+
+ * sexp-parse.h: Moved to ../common.
+
2004-01-24 Werner Koch <[email protected]>
* call-scd.c (atfork_cb): New.
@@ -437,7 +441,7 @@
* protect.c (agent_get_shadow_info): New.
* protect.c (snext,sskip,smatch): Moved to
- * sexp-parse.h: new file.
+ * sexp-parse.h: New file.
* divert-scd.c: New.
2002-02-27 Werner Koch <[email protected]>
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 400aa2fd2..65af03368 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -41,8 +41,7 @@ gpg_agent_SOURCES = \
trustlist.c \
divert-scd.c \
call-scd.c \
- learncard.c \
- sexp-parse.h
+ learncard.c
gpg_agent_LDADD = ../jnlib/libjnlib.a ../common/libcommon.a \
diff --git a/agent/sexp-parse.h b/agent/sexp-parse.h
deleted file mode 100644
index 89aa7210f..000000000
--- a/agent/sexp-parse.h
+++ /dev/null
@@ -1,99 +0,0 @@
-/* sexp-parse.h - S-Exp helper functions
- * Copyright (C) 2002, 2003 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-#ifndef SEXP_PARSE_H
-#define SEXP_PARSE_H
-
-#include <gpg-error.h>
-
-/* Return the length of the next S-Exp part and update the pointer to
- the first data byte. 0 is returned on error */
-static inline size_t
-snext (unsigned char const **buf)
-{
- const unsigned char *s;
- int n;
-
- s = *buf;
- for (n=0; *s && *s != ':' && (*s >= '0' && *s <= '9'); s++)
- n = n*10 + (*s - '0');
- if (!n || *s != ':')
- return 0; /* we don't allow empty lengths */
- *buf = s+1;
- return n;
-}
-
-/* Skip over the S-Expression BUF points to and update BUF to point to
- the chacter right behind. DEPTH gives the initial number of open
- lists and may be passed as a positive number to skip over the
- remainder of an S-Expression if the current position is somewhere
- in an S-Expression. The function may return an error code if it
- encounters an impossible conditions */
-static inline gpg_error_t
-sskip (unsigned char const **buf, int *depth)
-{
- const unsigned char *s = *buf;
- size_t n;
- int d = *depth;
-
- while (d > 0)
- {
- if (*s == '(')
- {
- d++;
- s++;
- }
- else if (*s == ')')
- {
- d--;
- s++;
- }
- else
- {
- if (!d)
- return gpg_error (GPG_ERR_INV_SEXP);
- n = snext (&s);
- if (!n)
- return gpg_error (GPG_ERR_INV_SEXP);
- s += n;
- }
- }
- *buf = s;
- *depth = d;
- return 0;
-}
-
-
-/* Check whether the the string at the address BUF points to matches
- the token. Return true on match and update BUF to point behind the
- token. Return false and dont update tha buffer if it does not
- match. */
-static inline int
-smatch (unsigned char const **buf, size_t buflen, const char *token)
-{
- size_t toklen = strlen (token);
-
- if (buflen != toklen || memcmp (*buf, token, toklen))
- return 0;
- *buf += toklen;
- return 1;
-}
-
-#endif /*SEXP_PARSE_H*/